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Change history
January 2024
• Added HTML‑based template forms.

• Added the boost feature.

• Added information on creating custom buttons.

• Added information on publishing administrator.

July 2023
• Added information on the following:
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• Template suites
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• Added information on the following:
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January 2022
• Added information on the following:
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September 2021
• Added information on user rights and access.
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– Editing a batch
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– Last used printer
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– Paper tray
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– Browser prerequisites

• Added instructions on managing print jobs.

September 2020
• Updated the instructions on the following:

– Creating a sign

– Creating a sign within a batch
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• Updated instructions on the following:

– Editing a sign

– Creating a sign

– Creating a sign view

September 2019
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• Added instructions on the following:

– Adding a sign to a batch

– Copying a sign

– Deleting a sign from a batch

– Copying a batch

– Deleting a batch

– Configuring the Item Library

• Deleted instructions on creating a sign with multiple items.

December 2018
• Initial document release.
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Overview
The Publishing Solutions portal is a component of the Lexmark Publishing Platform for Retail (PPR) software. It
lets you create, manage, or print signs for your store‑labeling requirements.

This document provides instructions on how to configure and use the portal.
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Supported browsers

Browser support and prerequisites

Supported browsers
• Microsoft Edge

• Google ChromeTM

• Apple Safari—in MacOS only, not Windows

• Mozilla Firefox

Notes:

• This release is not completely optimized for all small-screen or touch-screen devices.

• In non-Windows operating systems, including mobile devices, client-side printing is not supported.

Browser prerequisites
To let the application work properly, cache and local storage must be enabled.

Notes:

• Always set the Mozilla Firefox browser in Remember History mode.

• Some settings do not work in Incognito mode.
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Getting started

Switching applications
Publishing Solutions consists of the following applications:

• In-Store Publisher

• Signage Administrator

Note: These instructions apply only to users with access to these applications.

1 From the portal, click  on the upper‑right corner of the page.

2 From the list, select In-Store Publisher or Signage Administrator.

Notes:

• For both the applications, the user logs in as an In-Store user.

• When the user selects a particular application, the portal directs to the landing page of that application.
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In-Store Publisher

Signs

Creating a sign
The following instructions are for creating a sign in a new batch. To create a sign in an existing batch, see
“Creating a sign within a batch” on page 12.

Notes:

• Users must have the rights to create a sign within a batch.

• Some users do not have the rights to create signs in specific batches, although they can create signs in
general.

• Not all users have access to the default batch source.

From the Item Library

Make sure that your items are added in the Item Library.

1 From the home page, click Create Signs From Library.

2 Type a batch name, and then click Create.

Note:  Click More Information to modify other settings of the batch.

3 Click , select a template, and then click Select Template.

Notes:

• The selected template is applied to the new items in the batch.

• To edit the template for each sign, see “Editing a sign” on page 14.

• Sometimes, the administrator may configure the signs to be created after collecting the actual data
from the source. In this case, a Signs will be created with external item
information message appears, and the populated data may differ from data on the item library.

4 Select one or more items, and then click Add to Batch.

Note: You can search for signs and batches using multiple sign attributes. Click Advanced Sign Search,
enter multiple sign attributes separated by commas, and then click Search.

From a template

1 From the home page, click Create Signs From Template (Ad Hoc).

2 Type a batch name, and then click Create.

Note: Click More Information to modify other settings of the batch.

3 From the Current Template section, click , select a template, and then click Change Template.
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For a single-item template

a Select a single‑item template, and then click Change Template.

b In the Product Information field, type the item information.

For a multiple‑item template

a Select a multiple‑item template, and then click Change Template.

b Provide the header name, header description, and number of copies.

c In the Product Information section, do one or more of the following:

• Click Add from Item Library, and then select one or more items.

• Click Add Manually, and then provide the item information.

4 Click Save Sign.

Note: You can set up Platform Administrator to look up item details automatically using the UPC and SKU
fields in the Product Information section. To do this, set the control type of that field to TEXTSEARCH in
Platform Administrator.

From a planogram

This feature is available only if it is enabled in the In‑Store Publisher configuration settings from Platform
Administrator.

1 From the home page, click Create Signs from Planogram.

2 Type a batch name, and then click Create.

Note:  To change other settings of the batch, click More Information.

3 Click , select a template, and then click Select Template.

Notes:

• The selected template is applied to the new items in the batch.

• If Auto Assign Template is selected, then signs are created with this template or according to the
default rule set by the system administrator.

• If any other template is selected, then signs are created with this template or according to the rule
set by the system administrator.

• To edit the template for each sign, see “Editing a sign” on page 14.

4 Select a planogram, and then click Add to Batch.

Notes:

• You can select only one planogram at a time while adding to a batch.

• You can view the items present in a planogram by clicking the link in the Plano Code column.

From the Express Batch Builder

This option helps you create a batch of signs from the item library in an express way.

1 From the home page, click Express Sign Entry.

2 Type a batch name, and then click Create.

Note:  Click More Information to modify other settings of the batch.
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3 In the Express Sign Entry window, enter the necessary information.

Note: The selected template is applied to the new items in the batch.

4 Select one or more items, and then click Search and Add.

Note: You can search for signs and batches using multiple sign attributes. Click Advanced Sign Search,
enter multiple sign attributes separated by commas, and then click Search.

Creating a sign within a batch

Notes:

• Users must have the rights to create a sign within a batch.

• Some users do not have the rights to create signs in specific batches, although they can create signs in
general.

• Not all users have access to the default batch source.

From the Item Library

Make sure that your items are added in the Item Library.

1 From the Batches page, click a batch name.

2 Click Add Signs > Using item library.

3 Click , select a template, and then click Select Template.

Notes:

• The selected template is applied to the new items.

• To edit the template for each sign, see “Editing a sign” on page 14.

Note: Sometimes, the administrator may configure the signs to be created after collecting the data from
the source. In this case, a Signs will be created with external item information
message appears, and the populated data may differ from data on the UI.

4 Select one or more items, and then click Add to Batch.

Note: You can search for signs and batches using multiple sign attributes. Click Advanced Sign Search,
enter multiple sign attributes separated by commas, and then click Search.

From a planogram

This feature is available only if it is enabled in the In‑Store Publisher configuration settings from Platform
Administrator.

1 From the Batches page, click a batch name.

2 Click Add Signs > Using Planogram.

3 Click , select a template, and then click Select Template.

Notes:

• The selected template is applied to the new items in the batch.

• If Auto Assign Template is selected, then signs are created with this template or according to the
default rule set by the system administrator.
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• If another template is selected, then signs are created with this template or according to the rule set
by the system administrator.

• To edit the template for each sign, see “Editing a sign” on page 14.

4 Select a planogram, and then click Add to Batch.

Notes:

• You can select only one planogram at a time while adding to batch.

• You can view the items present in a planogram by clicking the link in the Plano Code column.

From a template

1 From the Batches page, click a batch name.

2 Click Add Signs > By Manual Entry.

3 Click , select a template, and then click Change Template.

For a single-item template

a Select a single‑item template, and then click Change Template.

b In the Product Information field, type the item information.

For a multiple‑item template

a Select a multiple‑item template, and then click Change Template.

b Provide the header name, header description, and number of copies.

c From the Product Information section, do one or more of the following:

• Click Add from Item Library, and then select one or more items.

• Click Add Manually, and then provide the item information.

4 Click Save Sign.

From the Express Batch Builder

1 From the Batches page, click a batch name.

2 Click Add Signs > By Express Entry.

3 In the Express Sign Entry window, enter the necessary information, and then click Search and Add.

4 Select one or more items, and then click Search and Add.

Note: You can search for signs and batches using multiple sign attributes. Click Advanced Sign Search,
enter multiple sign attributes separated by commas, and then click Search.

Adding and editing multiple signs
You can add and edit multiple signs at once before adding them to a batch.

1 From the Batches page, click a batch name.

2 Click Add Signs, and then select Using Item Library.
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3 Select the check boxes for the applicable items, and then click Add & Edit Items.

4 From the Create or Edit page, enter or modify the necessary information for each item, and then click
Save.

Note: You can navigate through signs by clicking Prev, Next, or the navigation buttons.

Editing a sign

Notes:

• Users must have the rights to edit a sign within a batch.

• Some users do not have access to edit signs in some specific batches, though they can have access to
edit signs in general.

• Not all users have access to the default batch source.

1 From the Batches page, click the batch name.

2 Click the product name, and then configure the sign information.

Note: To edit the template, click , and then select a template.

3 Click Save Sign.

Editing multiple signs
Users can edit templates and copies of multiple signs.

Editing templates

1 From the Batches page, click the batch name.

2 Select one or more signs, and then click Change Template .

3 To change a template, select a new template, and then click Change Template.

Changing copies

1 From the Batches page, click the batch name.

2 Select one or more signs, and then click Change Copies .

3 To change the copies, enter or select the number of copies, and then click Save

Configuring hyperlinks
A hyperlink detail lets you link the data to an external site with the ability to pass variables. To configure
hyperlinks in the Sign View page, do the following:

Prerequisites
• Do the required configuration in the Publishing Platform Manager (PPM) portal.

• In the Content management system (CMS) page, add the specific column to appear in the grid view of the
In-Store Publisher portal. Then set it to hyperlink.
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For a single-item sign

1 Go to the Sign View page.

Notes:

• In the sign item table, the column is updated with the key information provided in PPM.

• If the column already holds any data, then the column shows the existing data only.

2 Click the hyperlink in the column to access the external site.

For multiple‑item signs

1 Go to the Sign View page, and then click .

Note: In the Multi Item Details window, the column is updated with the key information provided in PPM.

2 Click the hyperlink in the column to access the external site.

Zooming a preview sign
In the Sign Edit page, you can preview the template before printing.

• When you see the message Click on image to zoom in, click  to zoom in the image

• When you see the message Click on image to zoom out, click  to zoom out.

Editing a batch

Notes:

• Users must have the rights to edit a batch.

• Some users do not have access to edit some specific batches, although they have access to edit
batches in general.

• Not all users have access to the default batch source.

1 From the Sign View page, click  beside the batch title.

2 Configure the batch information, and then click Update.

Printing a sign

Notes:

• Users must have the rights to edit a sign within a batch.

• Some users do not have access to edit signs in some specific batches, although they have access to edit
signs in general.

• Not all users have access to the default batch source.

1 From the Batches page, click the batch name.

2 Select one or more signs, and then click Print.
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3 If necessary, change the print settings.

4 Click Print.

For more information on printing, see “Print jobs” on page 18.

Copying a sign

Notes:

• Users must have the rights to copy a sign.

• Some users do not have the rights to copy signs to specific batches, although they can copy signs in
general.

• Not all users have access to the default batch source.

• Restricted batches do not appear in the option list.

1 From the Batches page, click the batch name.

2 Select one or more product names, and then click Copy.

3 Copy the sign to the same batch, a different batch, or a new batch.

4 Click Yes to confirm.

5 Go to the target batch where the sign items are copied.

Deleting a sign from a batch
Note: Users must have the required access to delete a sign.

1 From the Batches page, click a batch name.

2 Select one or more product names, and then click Delete > OK.

Updating the library
• Users must have the required access to update the library. The associated profile property is

LibraryPermissions.

• If the value of the profile property UpdateLibraryOnSignSave is set to TRUE, then users can see either of
the following:

– Update Library button is not visible.

– The library is updated automatically every time a user saves a sign.

For an existing item (Item is a corporate data)

1 Open the sign edit page.

2 Edit the attributes, such as the name, template, sale price, and regular price, and then save the sign.

3 Click Update Library.

Note: You can verify the modified attributes in the item library page.
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For a new item (Item is a store level or local data)

1 Open the sign edit page.

2 Edit the attributes, such as the name, template, sale price, and regular price, and then save the sign.

3 Click Update Library.

4 Click Add in the confirmation box.

5 Type the details of the attributes, and then click OK.

Batches
A batch is a group of signs or labels that you can print all at once. For example, if you want to print the signs
for a store sale, then create the signs in one batch. Sending the batch to the printer prints all the signs in it.

Creating a batch
1 From the Batches page, click Create Batch.

2 Provide the batch information, and then click Create.

Editing a batch

Notes:

• Users must have the rights to edit a batch.

• Some users do not have access to edit some specific batches, although they have access to edit
batches in general.

• Not all users have access to the default batch source.

1 From the Batches page, select a batch, and then click Edit.

2 Configure the batch information, and then click Update.

Printing a batch
1 From the Batches page, select one or more batches, and then click Print.

2 If necessary, change the print settings.

3 Click Print.

For more information on printing, see “Print jobs” on page 18.
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Printing a manifest
You can print a sign manifest from the Batch View page for one batch at a time.

1 Select a batch from the Batch View page, and then and click Print Manifest.

2 If necessary, change the print settings.

Note: You can preview the manifest before proceeding to print.

3 Click Print.

For more information on printing, see “Print jobs” on page 18.

Copying a batch

Notes:

• Users must have the rights to copy a batch.

• Not all users have access to the default batch source.

• Restricted batches do not appear in the option list.

1 From the Batches page, select one or more batches.

2 Click Copy.

Deleting a batch
Note: Users must have the required access to delete a batch.

1 From the Batches page, select one or more batches, and then click Delete.

2 In the Delete Batches dialog, click OK.

Print jobs
The print job window lets you print batches or signs for the store labeling requirements. Try any of the following:

• Select print jobs from the right pane.

Notes:

– A job contains one or multiple templates.

– When the print job is successful, the next print job is selected automatically.

• Change the print settings from the left pane.

Previewing a print job
You can confirm the following information before printing:

• Template type

• Page layout

• Total number of pages
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Selecting a printer
The Print Jobs window shows the last used printer in the client machine for the logged‑in user, as a preselected
printer. If no last‑used printer information is available, then the application shows the Windows default printer
as a preselected printer.

Try one of the following:

• Select the preselected printer.

• Click Change Printer to select another printer.

Note: If the Print Control Service is not installed and no last‑used‑printer information is available, then the
server default printer (if any) is automatically selected.

Selecting a tray
Tray information is automatically selected based on the configuration and availability.

Server‑side printing
• The tray option is visible only if the corresponding paper is associated with a tray.

Note: The tray is shown as a label (non-editable).

• If the tray is not configured, then the Paper Tray setting does not appear.

Client‑side printing
• The tray option is preselected if the corresponding paper is associated with a tray and the tray is available

for the selected printer.

• If the tray is not configured, then the first tray in the local print queue list appears as preselected.

Note: You can change the tray option manually.

Other print settings
You can select the following settings

• Select the Print as 1UP check box to print multiple pages onto a single paper.

• Select the check box to include any background image from the template.

Printing selected jobs
This setting must be configured and managed only through Platform Administrator.

Note: You can select an individual template instead of all templates under the selected paper.

Setting the Bump Page values
You can set the Bump Page values to offset the sign or label based on the X and Y parameters. You can enable
this setting only through Platform Administrator.

1 From the Batches page, select one or more batches, and then click Print.

2 From the Print Job page, change the print settings, if necessary.
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3 Click More Settings, and then type the values in the X‑offset and Y‑offset fields.

Notes:

• We recommend turning off Troubleshooter when you set the Bump Page values.

• For the Y parameter, the page is shifted upward if the Print API setting is set to WINDOWS. The page is
shifted downward if Print API setting is set to POSTSCRIPT.

• To use the Bump Page feature, use Print Control Service version 11.1 or later.

Troubleshooting
Note: This option is available only to Troubleshooter type users.

Users can configure the following settings:

• Print API, print method, printer model, and print graphics method

• Print target where the server printer is selected

• Local graphics, log level, and cache location for the local printer

Notes:

• The saved changes are applied in subsequent print jobs.

• To reset the settings, click Reset to Default.

Changing a store

1 From the portal, click  on the upper‑right corner of the page.

2 Click Change Store.

3 Select a store, and then click Change Store.

Notes:

• User must have the required permission to access more than one store.

• User can select a different store without logging out from the portal.

Changing the language

1 From the portal, click  on the upper‑right corner of the page.

2 Click Change Language.

3 Select a language, and then click Change Language.

Configuring custom buttons
1 Log in to the Signage Administrator.

2 From the Batch View menu, select Page.
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3 Click New Custom Button, and then configure the following:

• Button Text

• Button ID

• Button Icon

Note: If no button icon is specified, then the application uses a generic icon.

4 From the Define Functionality section select either of the following:

• Deploy API

• Configure URL

5 If you selected Configure URL, then type the embedded link.

6 If you selected Deploy API, then configure the following:

• API Name

• API Type

• API Parameter

7 Click Save.
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Signage Administrator

Configuration
Note: These instructions are available only for users with administrator access.

Configuring the home screen
1 From the navigation bar, click the UI Configuration tab.

2 Click Home Screen in the left pane.

3 From the Available Tiles section, configure the dashboard tiles to be shown in the home screen. Do either
of the following:

• To move a tile, click a tile, and then click either  or .

• To rearrange the tiles, click a tile, and then click either  or .

4 From the Tile Column section, increase or decrease the number of columns.

Note: The maximum number of tile columns is five.

5 Click Save Changes.

Configuring a batch page
1 From the navigation bar, click the UI Configuration tab.

2 In the Batch View menu, click Page.

3 From the Action Buttons section, configure the actions to use for the batch table. Do either of the following:

• To move an action, click the action, and then click either  or .

• To rearrange the enabled actions, click an action, and then click either  or .

Note: The actions on the right side of the Available Items field are enabled.

4 From the Table Columns section, configure the columns.

Notes:

• To add a column, click Add Columns, and then select a column.

• To delete a column, click  beside the column name.

• To include the column information in the search index, enable Searchable.

5 From the Default Rows Per Page section, set the number of rows to show for each batch page.

6 From the Batch Print Status Mapper section, configure the display value for each batch status.

Notes:

• To add a value mapper, click Add.
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• To delete a value mapper, click  .

7 Click Save Changes.

Configuring a batch view

Creating a batch view
1 From the navigation bar, click the UI Configuration tab.

2 In the Batch View menu, click Views > Create.

3 From the General section, type a unique name and description.

4 If necessary, add one or more queries.

5 From the Table Columns section, select the columns to use for the batch table. Do one or more of the
following:

• To enable a column, click the column name in the Available Items field, and then click .

• To rearrange the enabled columns, click a column name, and then click either  or .

Note: The column names on the right side of the Available Items field are enabled.

• To allow user updates, select In‑line Editable.

• To show more information for items on the column, select Hyperlink.

6 If necessary, add filters and facets. Do one or more of the following:

Note: Filters and facets are batch filters that appear on the left side of the batch view columns.

• To enable a filter, click the filter name in the Available Items field, and then click .

• To rearrange the enabled filters, click a filter name, and then click either  or .

Notes:

– The filter names on the right side of the Available Items field are enabled.

– Click  next to the filter name to edit the filter.

7 From the Default Sort Order section, select a batch attribute in the ascending/descending order.

8 Click Create Batch View.

Editing a batch view
1 From the navigation bar, click the UI Configuration tab.

2 In the Batch View menu, click Views.

3 Click a batch view.

4 Configure the batch view settings.

5 Click Save Batch View.
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Setting a default batch view
1 From the navigation bar, click the UI Configuration tab.

2 In the Batch View menu, click Views.

3 Select a batch view, and then click Set as Default.

Deleting a batch view
1 From the navigation bar, select the UI Configuration tab.

2 In the Batch View menu, click Views.

3 Select a batch view, and then click Delete > OK.

Note: You cannot delete a system‑provided batch view.

Configuring a sign page
1 From the navigation bar, click the UI Configuration tab.

2 In the Sign View menu, click Page.

3 From the Toolbar Buttons section, configure the actions to use for the sign table. Do either of the following:

• To move an action, click the action, and then click either  or .

• To rearrange the enabled actions, click an action, and then click either  or .

Note: The actions on the right side of the Available Items field are enabled.

4 From the Table Columns section, configure the columns.

Notes:

• To add a column, click Add Columns, and then select a column.

• To delete a column, click  beside the column name.

• To include the column information in the search index, enable Searchable.

5 From the Default Rows Per Page section, set the number of rows that you want to appear for each sign
page.

6 From the Advanced Search Attributes section, configure the attributes that you want to appear in the
advanced search. Do either of the following:

• To move an attribute, click the column name, and then click either  or .

• To rearrange the enabled attributes, click an attribute name, and then click either  or .

Notes:

– The attribute names on the right side of the Available Items field are enabled.
– We recommend selecting only up to 10 attributes.

7 From the Sign Print Status Mapper section, configure the display value for each batch status.
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Notes:

• To add a value mapper, click Add.

• To delete a value mapper, click .

8 Click Save Changes.

Configuring a sign view

Creating a sign view
1 From the navigation bar, click the UI Configuration tab.

2 In the Sign View menu, click Views > Create.

3 From the General section, provide a unique name and description.

4 From the Layout section, select the columns to show for the sign table. Do one or more of the following:

• To enable a column, click the column name in the Available Items field, and then click .

• To rearrange the enabled columns, click a column name, and then click either  or .

Note: The column names on the right side of the Available Items field are enabled.

• To allow user updates, enable In‑line Editable.

• To show more information for the items on the column, enable Hyperlink.

5 If necessary, add filters and facets. Do one or more of the following:

Note: Filters and facets are sign filters that appear on the left side of the batch view columns.

• To enable a filter, click the filter name in the Available Items field, and then click .

• To rearrange the enabled filters, click a filter name, and then click either  or .

Note: The filter names on the right side of the Available Items field are enabled.

6 Click  next to the filter name to edit the filter.

7 From the Rules section, add conditions or group rules.

8 From the Default Sort Order section, select a sign attribute in the ascending/descending order.

9 Click Create Sign View.

Editing a sign view
1 From the navigation bar, click the UI Configuration tab.

2 In the Sign View menu, click Views.

3 Click a sign view, and then configure the settings.

4 Click Save Sign View.
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Deleting a sign view
1 From the navigation bar, click the UI Configuration tab.

2 In the Sign View menu, click Views.

3 Select a sign view, and then click Delete > OK.

Note: You cannot delete the default sign view.

Creating HTML based template forms

Creating template forms
1 From the top navigation bar, click Template Forms.

2 Type the form name and description.

3 From the Form Editor, click Upload, and then select the form.

Note: You can also write an HTML form directly from the Form Editor.

4 If necessary, modify the form.

5 Click Save.

Configuring profile properties in HTML
Note: When using signed edit pages, two properties are impacted: ChangeCopies and batch read only.

1 From the PPR website, log in as a template administrator.

2 Click Template Forms, and then change the properties in the Form Editor page.

Note: Profile properties are case‑sensitive. Make sure to use the same case in the PPM portal.

3 In the PPM, set Add or Remove Properties for a Profile to either True or False.

Note: Some features of the profile templates are not accessible depending on the values set in PPM.

4 Log in to the PPM, and then navigate to the Batches tab to check if the changes in the properties are set.

Creating profile properties

1 In the PPM, click Profiles > Profile Properties > New.

2 Provide the following:

• PROPERTYNAME and DESCRIPTION

• TYPEID and CLASSID

• CLASSNAME

3 Click Save.

4 From the profile, select AvStoreGroupManager.
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5 Click Add, and then select the created property name.

6 Click Edit, and then provide a value.

Configuring NLS support in HTML
1 From theSQLQueryS.sql, go to the content management system table and add the new record with the text

ID.

Note: Make sure that the HTML form name is one of the supported forms.

2 From the template forms, find the form name.

3 From the SQLQueryS.sql, create a text ID with HTML_“Form Name” format.

4 Input the The following values are used:

• Page is the form name.

• Label is the key.

• Language is the language ID.

5 Click execute to run the query.

6 From the template form, map the label with your HTML property.

7 Click preview.

Note: All languages currently supported in Lexmark works here.

Setting up hyperlinks in the content management system
1 From the PPM portal, open the AV Admin and AV admin properties files.

2 Update the value to 15.

3 Log in to the Signage Administrator, and then click Hyperlink Settings.

4 Click Add, and then type the following:

• View

• Column

• Hyperlink Value

Note: Make sure to enter the correct format of the hyperlink value.

5 Click Save.

6 From the Sign view section, click Page.

7 From the Table Column section, click Add Column.

8 Add the column that is set in the hyperlink settings.

9 From the added column, select hyperlink.

10 Click Save Changes.
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Configuring the item library
1 From the navigation bar, click the UI Configuration tab.

2 Click Item Library > Choose Fields.

a In the Add Columns dialog, select the column names to use on the Item Library table, and then click
Add Columns.

b Configure the selected columns. Do one or more of the following:

• Set the column data type.

• To include the column information in the search index, enable Searchable.

• To delete a column, click  beside the column name.

3 From the Advanced Search Attributes section, configure the attributes that you want to appear in the
advanced search. Do either of the following:

• To move an attribute, click the column name, and then click either  or .

• To rearrange the enabled attributes, click an attribute name, and then click either  or .

Notes:

– The attribute names on the right side of the Available Items field are enabled.
– We recommend selecting only up to 10 attributes.

4 From the Table Columns section, configure the columns that you want to appear. Do one or more of the
following:

• To move a column, click the column name, and then click either  or .

• To rearrange the enabled columns, click a column name, and then click either  or .

Note: The column names on the right side of the Available Items field are enabled.

5 From the Default Rows Per Page section, set the number of rows that you want to appear when viewing the
Item Library.

6 If necessary, add filters and facets. Do one or more of the following:

Note: Filters and facets are item filters that appear on the left side of the Item Library page.

• To enable a filter, click the filter name in the Available Items field, and then click .

• To rearrange the enabled filters, click a filter name, and then click either  or .

Note: The filter names on the right side of the Available Items field are enabled.

7 From the Default Sort Order section, set the item attributes to appear in ascending or descending order.

8 Click Save Changes.
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Configuring custom localization

Updating the localization file
1 From the navigation bar, click the UI Configuration tab.

2 Click Localization > Download CSV File > Factory Default.

3 Select a language, and then click Download.

4 From your computer, open the CSV file.

5 In the Value column, replace the strings with their translations, and then save the document.

Uploading the localization file
1 From the navigation bar, click the UI Configuration tab.

2 Click Localization > Upload.

3 Select a language, and then browse to the updated CSV file.

4 Click Upload.

Managing templates
Note:  These instructions apply only to users with signage administrator access.

Importing templates
Note: Users must have access to import a template.

1 From the top navigation bar, click the Templates tab.

2 Click Import.

3 Select one or more valid PTF or ZIP files.

Notes:

• Valid templates data is extracted and is redirected to the Review Template Changes page.

• The Review Template Changes page shows information such as template name, description, source
file, export time, and status.

• If the review list contains any duplicate template, then importing is not allowed. The Apply button
remains disabled.

• Users can remove a duplicate template by clicking .

4 Click Apply.

5 Review the final changes, and then click Yes.

6 Click Done to go back to the template view.
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Exporting templates

Notes:

• Users must have access to export templates.

• The template page is searchable by template name and description.

• The template page is paginated and sortable.

• Users must select at least one template to enable the Export button.

1 Select one or more templates.

2 Click Export.

Notes:

• When exporting a single template, a PTF (Portable Template Format) file is downloaded as
<Template Name>.ptf.

• When exporting multiple templates, a ZIP file is downloaded, which contains a PTF file for each
selected template.

Creating a template
1 From the top navigation bar, click Portfolio, and then click the Templates tab.

Note: You can customize the columns on the Templates page by clicking Columns, and then selecting
the check boxes for the columns that you want to appear on the page.

2 Click New.

3 From the Create Template page, enter the necessary information, and then click Save.

You can also do other tasks on the Templates tab:

• Edit, copy, or delete a template.

• Filter the list of templates in the table by searching for a keyword using the Search box or by using the Filters
section in the left panel.

• Adjust the number of rows in the table using the View menu. This setting applies to the Templates, Template
Assignments, Template Suites, and Template Groups tabs.

Creating a template group
A template group contains templates that are designed for similar purposes.

1 From the top navigation bar, click Portfolio, and then click the Templates Groups tab.

2 Click Create.

3 From the Create Template Groups page, enter the necessary information, and then click Save.
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You can also do other tasks on the Templates Group tab:

• Edit or delete a template group.

Note: You cannot delete a template group if there are templates associated with it. From the Template
tab, you must remove delete the template entry associated with the template suite.

• Filter the list of templates in the table by searching for a keyword using the Search box or by using the Filters
section in the left panel.

Creating a template suite
A template suite contains a batch of templates that are shared by multiple stores.

1 From the top navigation bar, click Portfolio, and then click the Templates Suites tab.

2 Click Create.

3 From the Create Template Suite page, enter the necessary information, and then click Save.

You can also do other tasks on the Templates Suites tab:

• Edit or delete a template suite.

Note: You cannot delete a template suite if there are templates associated with it. From the Template tab,
you must delete the template entry associated with the template suite.

• Filter the list of templates in the table by searching for a keyword using the Search box or by using the Filters
section in the left panel.

Creating template rules
You can add conditions or rules to your templates.

1 From the top navigation bar, click Portfolio, and then click the Templates Assignments tab.

2 Click Create.

3 From the Create Template Assignment page, enter the necessary information about the rule.

4 To add a condition or rule to the template, click beside Rule Details, and then enter the necessary details.

5 Click Save.

Note: To view the details of the condition or rule, click in the Actions column.

You can also do other tasks on the Edit Template Assignment page:

• Edit or delete a template rule or template assignment.

• Filter the list of templates in the table by searching for a keyword using the Search box or by using the Filters
section in the left panel.

Creating paper types
1 From the top navigation bar, click Portfolio, and then click the Templates Groups tab.

2 Click Create.

Signage Administrator 31



3 From the Create Template Groups page, enter the necessary information, and then click Save.

You can also do other tasks on the Paper Types tab:

• Edit or delete a paper type.

• Filter the list of templates in the table by searching for a keyword using the Search box or by using the Filters
section in the left panel.

Using Template Migration Utility
Template Migration Utility is a desktop application that helps users to export and import templates.

Note: You can also access Template Migration Utility through Template Designer. In Template Designer, click
File > Template Migration Utility. When a confirmation dialog appears, click Yes.

Template Migration Utility consists of two pages:

• Configuration page

• Template page

Do one or more of the following:

• In the Configuration page, enable the Connect button by providing the user ID, password, and data source.

The Connect button is disabled by default.

• If the database connection is established successfully, then access the Template page.

Exporting a template

1 Select one or more templates from the list.

2 Click Export, and then select a destination folder.

3 Click Save.

Notes:

• When the template is successfully exported, a confirmation message appears along with the new file
name.

• In the desktop application, click Show in folder to open the destination folder.

Searching a template

1 Type the keyword in the search box, and then click Enter.

2 To go back to the original list of templates, clear the search box, and then click Enter.

3 Click OK.

Importing a template

1 Click Import.

2 From File Explorer, select the ZIP file, and then click Open.

3 In the Review Templates for Import page, click Import Now.

Note: For conflicted templates, the progress status appears as Conflict. These templates are not
imported at the first attempt.
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4 In the Duplicates layers detected window, do either of the following:

• Replace existing layers with duplicate layers.

• Keep existing layers.

Note: Click View details to see the details of the impacted templates.

5 Click Done.
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Publishing Administrator

Distributing the batches

Creating batches

1 From the navigation bar, click the Batches tab.

Notes:

• The list of batches from the stores are listed when navigating to the Batches tab.

• The Columns section filters the information that you want to show in the batch list.

• From the Actions column, you can edit or preview the batch details.

2 Click Create Batch, and then enter the required information.

3 Click Save.

Changing the status

1 Select one or more batches from the batch list.

2 Click Change Status, and then select the status type.

3 Select the status value, and then click Update.

Choosing more options

If necessary, choose one of the following:

• Copy Batches—Create a copy of a particular batch.

• Hide to Stores—Hide a particular batch.

• Show to Stores—Show the batch in the list.

• Delete Permanently

• Batch Validation—Validate a batch for issues.

Note: You can export the list from the batch validation to a CSV file.

Editing a store list
This section describes how to distribute the batches to the listed stores.

1 From the navigation bar, click the Store List tab.

Notes:

• The stores are listed when navigating to the Store List tab.

• The Columns section filters the information that you want to show in the batch list.

• From the Actions column, you can edit the batch details.

2 Click , and then enter the required information.

Note: When editing the number of stores, you can filter stores by city or state.
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3 Click Save.

4 If necessary, click Create to add a store to the list.

Distributing events
This section describes how to view the number of batches distributed to the stores.

1 From the navigation bar, click the Batches tab.

Notes:

• The stores are listed when navigating to the Store List tab.

• The Columns section filters the information that you want to show in the batch list.

• From the Actions column, the user can edit the batch details.

2 Select the number of batches to distribute to the stores.

3 Click Distribute, and then fill out the required fields.

4 Select the distribution type, and then click Next.

Note: There are two types of distribution: Distribute Now, and Save in Queue.

5 Click the Distribution Events tab.
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Edition notice
February 2024

The following paragraph does not apply to any country where such provisions are inconsistent with local
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All other trademarks are the property of their respective owners.
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