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Overview

Note: The screenshots may vary depending on the latest release.

Make sure that you have read through the "Getting Started" section before proceeding.
This section describes the recommended process of rolling out Lexmark Cloud Fleet 
Management and Cloud Print Management. This knowledge helps you to start managing 
your fleet and printing with the full capabilities of Lexmark Cloud Services.

"Manage your organization" group

Set how users authenticate with Lexmark Cloud Services and default user roles.
For channel partners, create customer (child) organizations.

"Add and edit your users" group

Create user accounts and set system permissions.
"Enroll your printers" group

Register printers with Lexmark Cloud Services and enable remote management.
Select the agents to use.

"Deploy applications and configure your printers" group

Remotely configure printers with eSF applications and device settings using Cloud 
Fleet Management tools.

"Customize your print environment" group

Note: Applicable only if Cloud Print Management is enabled for the organization.

Set up organizational policies, including print quotas and print delegates.
Select the print release clients to use.

"Using notification policies" group

Send email alerts on supplies levels, such as when the toner level is at or below a 
certain value.
Send email alerts on printer communications, such as when a data refresh has not 
occurred, or a printer has not communicated for a certain interval.

Manage your organization

Why I need to manage an organization?

There are many ways to set up an organization. The setup depends on how your company 
operates and in the case of channel partners, how their customers operate their business.
Consider these factors when managing an organization:

Rollout Guide
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What printer models will be used?

Are they all Lexmark models?
Will third‑party printers be used?

Will a firewall or proxy server be used?
What enrollment agents do you plan to use?
What functions will each user perform as an administrator and as a user?
Will identity federation be used?
What embedded applications will be used on the printers?
Will users need to authenticate at the printer? If yes, how do they plan to authenticate?
Will Cloud Print Management be used?

What print management policies will need to be configured?
How will the user submit print jobs?
What submission clients will be used?

For channel partners, there are more factors to consider. If you plan to use child 
organizations, then the answer to each of these questions will help determine the user 
accounts required in the child organization, if any.

Will users in the channel partner organization need access to child organizations?
Who will perform the ongoing management of users in the child organization?
Will Cloud Print Management be used in the child organization?

Will the channel partner or someone from the end customer manage Cloud Print 
Management for the child organization?

Understanding the Account Management dashboard

The Account Management dashboard is the landing page of the Account Management 
portal. The Account Management portal lets you manage organizational settings, create 
and manage users, assign user roles, and create child organizations under channel 
partner organizations. What can be seen depends upon the roles of the user.

Note: A user must have either the Organization Administrator or User Administrator 
role to access the Account Management portal.

The following is a sample Account Management dashboard for a user with the 
Organization Administrator or User Administrator role.
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Organization
Users
Groups
Applications

The following is a sample Account Management dashboard for a user with the 
Organization Administrator or User Administrator role, and the Partner Administrator role.

Organization
Users
Groups
Applications
Child Organizations
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The Account Management dashboard provides access to the following:

The Organization menu, which provides links to the following:

The Account Management dashboard
The Organization Roles page—Lets you select a set of roles that are automatically 
assigned to all users in the organization
The Authentication Provider page—The setup for federated identity management
Child organizations—Lets you view child organizations defined under the partner 
organization.

Note: These organizations appear only to users who have the Partner 
Administrator role.

Printer Login Configuration
The Users card and menu:

Shows the list of user accounts in the organization
Lets you create new user roles and modify existing ones

The Groups card and tab:

Shows the list of user groups in the organization

Note: Groups provide a quick way to assign the same set of roles to several users.

The Applications tab:

Shows the list of installed applications that provide authentication credentials for 
devices without user credentials, such as Fleet Management Printer Agent and Cloud 
Print Management

The Child organizations card:

Shows the list of child organizations under an organization.

Note: This card appears only to users who have the Partner Administrator role.

Organization settings

Organization settings

The Organization menu provides quick access to various organizational settings and 
information.
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The Organization menu contains the following:

Organization Information—A link to the Account Management dashboard, which provides 
links to the user and group management pages

Note: For channel partners, there is also a link to the child organizations 
management page.

Organization Roles—Lets you select a set of roles that are automatically assigned to all 
users in the organization
Authentication Provider—The setup for federated identity management
Child Organizations—Lets you view child organizations defined under the partner 
organization

Note: This menu item appears only to channel partners.

Printer Login Configuration—Defines the user authentication modes allowed at printers

For more information, see "Managing printer logins" group in Lexmark Cloud Services 
Administrator's Guide.

Configuring user login at the printer

You must configure the authentication process for users who log in at the printer. If the 
user is accessing Lexmark’s cloud-based functionality, such as Cloud Fleet Management 
or Cloud Print Management, then logging in to the printer is required.
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From the Account Management web portal, click Organization > Printer Login 
Configuration.

The Organization Printer Login Configuration page allows you to select Single (Standard) 
and two-factor (Badge + PIN) authentication methods for user authentication.
You can either use Single (Standard) or two-factor (Badge + PIN) authentication methods for 
user authentication. Do either of the following:
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Standard authentication

One or more of the standard authentication methods can be enabled at the same time.

Badge—Uses contactless card reader and user ID badges. Badges must be 
registered before they can be used. For more information, see "Managing badges" 
topic in Lexmark Cloud Services Administrator's Guide.
PIN—Uses a 4‑digit to 12‑digit PIN. PINs can be set by the user, the administrator, or 
Lexmark Cloud Services. PINs can be set to never expire or to expire after 1 hour up 
to 180 days. For more information, see "Managing PINs" topic in Lexmark Cloud 
Services Administrator's Guide.

Note: If an authentication provider has been configured, the PIN Generation 
option must be set to Administrator manually set and to Never expire.

Secure login—Users must obtain a one-time PIN each time they authenticate at the 
printer. For more information, see "Configuring printer login" topic in  Lexmark Cloud 
Services Administrator's Guide.
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The one-time PIN can be obtained from either of the following:

The My Account page, in the Printer Login section
The Lexmark Print application, by clicking the cloud icon.

Note: If secure login is enabled for an organization, then the Secure 

Login icon appears on the printer control panel.

Badge + PIN as second factor

In this method users must use their badge and enter their PIN to authenticate. The badge 
and PIN stipulations as stated in the Standard Authentication section also apply.

The Cloud Authentication eSF application polls the cloud for changes to the Printer 
Login Configuration settings every 15 minutes.
The settings on the Printer Login Configuration page overwrite settings that are 
configured with the Cloud Authentication application installed in the printer.
These settings are applied to all printers in the organization.
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Understanding identity federation

Federation is the process of creating a trust relationship between a customer’s identity 
provider (IDP) and an external service, such as Lexmark Cloud Services. The identity 
provider can be Microsoft Azure Active Directory (Azure AD), Google Identity, or any other 
Security Assertion Markup Language (SAML) 2.0-compliant identity management system.
After this trust relationship is built, users can access Lexmark Cloud Services using the 
same credentials that they use for their other internal sites and services. The customer’s 
identity provider manages all aspects of credential management, including password 
validation, complexity of requirements, expiration, and potential use of multifactor 
authentication. Additionally, the identity provider can support Single Sign-On (SSO), which 
reduces the number of times users are required to authenticate as they switch between 
services.

Notes

Federation is supported by identity management services that use the SAML 2.0 
standard.
An organization can only be configured to federate with a single identity 
management provider.

To enable federation or to change the current federation configuration, do the following:

From the Account Management web portal, click Organization > Authentication Provider.

If federation is not enabled, then click Configure an Authentication Provider.
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3. Enter the details in the Authentication Provider form.
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Creating a child organization

Child organizations provide a means of grouping printers based on business needs. This 
grouping could be for customers of a channel partner or business units of an enterprise.

Note: You must have the Partner Administrator role to create and manage child 
organizations. For more information, see "Partner administrator" group Lexmark 
Cloud Services Administrator's Guide.

Do I need to create a child organization?

There are two ways of organizing your customers’ printers: a hierarchical structure or a flat 
structure. The structure you choose determines whether child organizations are needed.

Note: We recommend using the hierarchical structure for organizing your 
customers’ printers.

Hierarchical structure—Uses a child organization for each of your customers. The printers 
of each customer are grouped in that customer’s organization, separating printer information 
between customers. Also, a hierarchical structure lets you grant access to future Lexmark 
Cloud Services capabilities on a customer-by-customer basis.

Flat structure—A flat structure places all printers from all customers in a single structure. 
Any future Lexmark Cloud Services capabilities added to one customer are available to all.
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Purpose Hierarchical Flat

Identifying a customer’s 
printers

Printers for each customer 
are separated into different 
child organizations.

Printers must be tagged 
with an identifier to 
determine which customer 
is using it.

Finding a specific printer The customer must be 
known, or each child 
organization must be 
individually searched for the 
specific printer.

All printers are in one list.

Print activity reporting A customer’s printer activity 
can be easily determined by 
reporting on the print 
activity of the entire child 
organization.

A customer’s printer activity 
must be determined by 
filtering printers by 
customer-identifiable 
means. For example, you 
can filter printers by tags.

Future Lexmark Cloud 
Services functionality

Future Lexmark Cloud 
Services functionality can 
be selectively granted to 
individual customers.

Future Lexmark Cloud 
Services functionality made 
available to one customer is 
available to all. Some 
enhanced functionality may 
not be supported in a flat 
structure.

Account management by 
customers

A customer administrator 
can be added where 
needed in individual 
customer organizations 
without sharing access to 
information of other 
customers.

A customer administrator 
who is added can see all 
printer information for all 
customers.

Creating a child organization

In the Account Management web portal, click Organization > Child Organizations.
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2. Click Create.

Note: If there are no existing child organization, then click Create Child 
Organization.
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In the Organization name field, type a unique name and then click Create Child 
Organization.

Add and edit your users

Why do I need to manage users?

For users to use Lexmark Cloud Services, administrators must first create accounts for 
them based on their roles and responsibilities. It is common for a user’s roles to change 
over time. You can easily make changes to those roles after the initial setup is complete.
When creating Lexmark Cloud Services accounts for users, consider the following:

What do users need to have access to the cloud?
What functions will each user need to perform?

For channel partners, also consider the following if child organizations are created:

Will users in your organization need access to child organizations?
What users do you need to create in the child organization, and what functions will they need 
to perform?

Adding users

To give a user access to Lexmark Cloud Services, administrators must first create 
accounts for them in an organization in Lexmark Cloud Services. You can create user 
accounts in one of the following ways.

Using the Add User form in the Account Management portal
Importing users using a file in the Account Management portal
Using federated identity management

Creating users manually by using the Add User form

You can create an account for a user manually in Lexmark Cloud Services by typing the 
user’s information in the Add User form. Only one account can be created at a time. Use 
this method if you are adding only a few users.
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From the Account Management web portal, click Users.
Click Create User or Create.

Type the following details:

E‑mail—Must be your Lexmark Cloud Services account name.
First Name
Last Name
Display Name—The name that you want to appear in the Lexmark Cloud Services 
portal when you log in.
Department
Cost Center
Set Password—This is required only when for Lexmark Customer Identity 
Management Services are used. The administrator can either manually set the user’s 
password or email a link to the user. Users can use that link to create their own 
password.
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4. Click Create User.

Importing users from a CSV file

You can create multiple user accounts simultaneously by importing them from a file. The 
Import feature lets you create, update, and delete multiple users in an organization using a 
CSV or TXT file. You can also create user groups, assign a user to those user groups, and 
set user PINs. For more information, see "Managing users" topic in Lexmark Cloud 
Services Administrator's Guide. Use this method if you are adding a large number of users.
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Notes

The CREATE command is used to create a new user account.
The headers of the import file are case‑sensitive.
Count the commas. All columns must be accounted for on each line of the CSV file.
The size of the CSV file must not exceed 1MB.

Creating users when using federated identity management

When federated identity management is used, you do not need to create or import users 
manually to create their accounts. A user account in a federated organization is 
automatically created when the user logs in to the following for the first time:

Lexmark Cloud Services portal
A Lexmark Cloud submission client
The Lexmark Print application

Creating a user account in a federated organization is useful in the following ways:

If your organization already uses an identity management system, then federating allows 
Lexmark Cloud Services to authenticate users with your identity management system. User 
accounts do not have to be manually created or imported into the Account Management 
portal. User credentials are not stored in Lexmark Cloud Services.
If user badges are not maintained in your authentication provider, then they can be manually 
added for each user. Or a list can be imported using the CSV file import function. This action 
pre-registers user badges.

Note: If your authentication provider maintains the users’ badges, then they can be 
obtained directly through a claim from your authentication provider. This also allows 
badges to be used without having to register them.

If the department or cost center definitions used in Lexmark Cloud Services do not 
correspond to definitions in your authentication provider, then you can resolve the mismatch. 
You can manually add missing definitions for each user, or you can import a list using the 
CSV file import function.

Note: If configured in the authentication provider setup, then user badges and 
department or cost center definitions can be obtained directly through claims from 
your authentication provider.
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Assigning roles

User roles

Roles are used to manage access to specific features within Lexmark Cloud Services. A 
user can be assigned roles using any of the following methods:

Assigning roles individually—Requires assigning roles manually to each user.
Assigning roles through groups—Allows a set of roles to be given to users by making 
them a member of a group. Users can be members of more than one group.
Inheritance through organization roles—Automatically assigns the organization roles to 
all users in the organization.

Note: For more information on user roles, see "Understanding roles" topic in 
Lexmark Cloud Services Administrator's Guide.

Determining what roles are needed

Before assigning roles, you must determine the features of Lexmark Cloud Services that 
your organization plans to use, and which individual users plan to use them.

Administrative roles for account management

There are two administrative roles for account management: the Organization 
Administrator and the User Administrator.

Organization Administrator

Role with the most privileges
Can manage organizational settings for your organization
Can manage user accounts for your organization

Can add and delete user accounts
Can add and remove roles assigned to user accounts
Can add and remove user accounts from groups

User Administrator

Can manage user accounts for your organization

Can add and delete user accounts
Can add and remove roles assigned to user accounts
Can add and remove user accounts from groups

For channel partners, users who manage the configuration, user accounts, or printers in a 
customer organization must be added to a Child Organization Access Group. For more 
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information, see "Managing the Child Organization Access Group" topic in Lexmark Cloud 
Services Administrator's Guide.

The following table lists the roles required for actions to be performed in a customer (child) 
organization:

Action Roles to assign to a child organization 
access group

Managing organizational settings Organization Administrator

Managing user accounts Organization Administrator or User 
Administrator

Managing printers Fleet Management Administrator

Managing Cloud Print Management Print Release Management Administrator

Roles for Cloud Fleet Management

Users enrolling printers in Cloud Fleet Management must have the Fleet Management 
Administrator and the File Service Administrator roles.
Users accessing Fleet Management reports but not enrolling printers in their organization 
must have the Fleet Management Reporting Analyst role.
Users enrolling a customer’s printers in Cloud Fleet Management must be added as 
members of a Child Organization Access Group. They must also be assigned the Partner 
Administrator, Fleet Management Administrator, and File Service Administrator roles.
Users accessing Fleet Management reports for printers in customer organizations but not 
enrolling printers must be added as members of a Child Organization Access Group. They 
must also be assigned the Partner Administrator, Fleet Management Reporting Analyst 
roles.

Roles for Cloud Print Management

The roles support two methods of print job submission and release: Cloud Print 
Management and Hybrid Print Management.

Submitted print jobs are stored in the Lexmark Cloud Service until the user releases it at a 
Cloud Print Management–enabled printer.

Users submitting and releasing print jobs using Cloud Print Management must have the 
Print Release Management User role.
Users managing Print Management for their organization must have the Print Release 
Management Administrator role.
Users generating organizational Cloud Print Management reports but not submitting and 
releasing jobs must have the Print Release Management Reporting Analyst role.
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Roles for Hybrid Print Management

Submitted print jobs are held on the user’s workstation until the user releases it at a Cloud 
Print Management–enabled printer that uses Hybrid Print Management.

Users using Hybrid Print Management must have the Hybrid Print Management User role.
Users managing Print Management for their organization must have the Hybrid Print 
Management Administrator role.
Users generating organizational Print Management reports but not using Hybrid Print 
Management must have the Print Release Management Reporting Analyst role.

Assigning roles to an individual

From the Account Management web portal, click Users > Users.
On the Users page, click the E‑mail of the user.

In the Assigned Roles section, click Edit.
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Do the following:

To assign a role, click Assign.

On the Assign Roles page, select or remove the roles.
Click Assign Roles.

To remove a role, select the role, and then click Remove > Remove Role.
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Assigning roles through groups

Assigning roles through groups allows a set of roles to be given to users by making them a 
member of a group. This method makes it easy to assign the same roles to multiple users.

Note: Users can be members of more than one group.

From the Account Management web portal, click Groups tab.
Do any of the following:

To create a new group, click Create.
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In the Group name field, type the name of the group.
Click Create Group.

To edit an existing group, click the group under the Group Name column.
On the Edit group page, do the following:

From the Members tab, add or remove members.
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◦ From the Group Roles tab, you can either assign or remove roles.
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Assigning roles by membership in a child organization access group

Notes

Child organization access groups are available only to channel partners.
Roles assigned through membership in a child organization access group apply 
across all customer organizations.

For channel partners, the Groups tab shows two tabs: Organization Access and Child 
Organization Access. Organization access groups apply only to the channel partner’s 
organization. Child organization access groups apply to the customer organization. The 
process for managing membership and roles for organization access and child 
organization access groups is the same.

The difference between organization access groups and child organization access groups 
is that child organization access groups are created with a default role, Partner 
Administrator. You cannot delete the Partner Administrator role from a child organization 
access group. You can add or remove additional roles as needed.
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The Partner Administrator role is required for users to have access to customer (child) 
organizations. For example, a user who will be managing printers in a child organization 
using Fleet Management must be a member of a child organization access group. 
Moreover, that child organization access group has the Fleet Management Administrator 
role added along with the default Partner Administrator role.

Assigning organization roles

Roles can be assigned at the organization level. Organization roles are automatically 
inherited by all users in the organization. For example, if all users can access Cloud Print 
Management, then they are all assigned the Print Release Management User or Hybrid 
Print Management User role. The roles can be automatically assigned to all users via the 
organization roles.

From the Account Management web portal, click Organization > Organization Roles.
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3.

Click Assign or Assign Roles.

From the Assign Roles page, add or remove roles.
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Click Assign Roles.

Managing user badges

If users are authenticating at the printer, then set up a badge or PIN for each user. For 
more information on badge configuration, see "Managing printer logins" group.
Assigning badges

If identity federation is used and badge IDs can be retrieved using claims from your identity 
management service, you can automatically populate badge IDs from the service.

Note: A user must log in to the Lexmark Cloud Services portal once before their 
badge ID is retrieved so that it can be used to authenticate at a printer.

If identity federation is not used or badge IDs are not available from your identity 
management service, then you can assign badge IDs in two ways. The method to use 
depends on how much of the process you want your users to participate in.

Assigned by an Organization Administrator or User Administrator in the Account 
Management portal—Can be done manually, one user badge at a time, or by importing 
from a CSV file, for multiple user badges
Assigned by the user—Can be done manually from the user’s My Accounts page, which 
requires users to provide their badge ID, or manually at the printer

Badges registered manually by an Organization Administrator or a User 
Administrator in the Account Management portal
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a.

b.
c.

From the Account Management portal, use any one of the following methods to access the 
Registered Badges page:

Note: If you are a channel partner with child organizations, then you must select the 
organization.

Using the Users card in the Account Management portal

Click the Users card.

Click the email address of the user.
In the Printer Login section, for the Badges login, click Edit.
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d. Click Register or Register Badge.
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e.

a.
b.

c.

2.

1.

In the Register Badge window, enter the badge information.
Using the Users menu

From the Users menu, click Manage Badge/PIN.
Click Register or Register Badge.

In the Register Badge window, enter the user’s email address and the badge 
information.

Note: The user's email address must already exist in the organization.

Click Register Badge.

Badges imported by an Organization Administrator or a User Administrator in the 
Account Management portal

From the Account Management portal, use one of the following methods to access the 
Registered Badges page:
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2.
3.

4.

5.

1.
2.

Note: If you are a channel partner with child organizations, then you must select the 
organization.

From the Users menu, click Manage Badge/PIN.
Click Import Badges.

In the Import Badges window, browse to the CSV or TXT file that contains the list of badges.

Note: For more information, see "Managing users" topic in Lexmark Cloud Services 
Administrator's Guide.

Click Import Badges.

Badge registered by users through their My Account page

This action can only be performed by users for their own badge.

From the Lexmark Cloud Services portal, in the username menu, click My Account.
On the My Account page, in the Printer Login section, for the Badges login, click Edit.
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3.

4.
5.

Click Register or Register Badge.

In the Register Badge window, enter the badge information.
Click Register Badge.
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1.
2.

3.

Badge registered by a user at the printer control panel

This action can only be performed by users for their own badge. Badges can be registered 
by users at the printer control panel using one of the following methods:

Manual badge registration using your email address and password

Tap your badge on a card reader that is attached to a printer.
From the control panel, touch Manual Registration.

In the Enter your existing account credentials field, type your email address and 
password.
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4.
•

1.
2.

3.

Touch Register.
Email badge registration request sent from the printer

Tap your badge on a card reader that is attached to a printer.
On the control panel, touch E‑mail Registration.

In the Send the registration link to field, type your email address.
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4.

5.

Touch Send > OK.

Open your email account, and then click the badge registration link.
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Note: The following screen appears for 5 seconds before logging you into the My 
Account page of Lexmark Cloud Services portal .

Managing user PINs

If users are authenticating at the printer, then set up a badge or PIN for each user. For 
more information on PIN configuration, see "Managing printer logins" group in Lexmark 
Cloud Services Administrator's Guide.
Assigning PINs

If identity federation is used and PINs can be retrieved using claims from your identity 
management service, you can automatically populate PINs from the service.

Notes

A user must log in to the Lexmark Cloud Services portal once before their PIN is 
retrieved, and it can be used to authenticate at a printer.
If PINs are retrieved from your identity management system, then you must set the 
PIN Generation menu to Administrator manually set and to Never expire.
Any PIN changes made in Lexmark Cloud Services is temporary. These temporary 
PINs are overwritten from your identity management system when the user logs in 
the next time.

If identity federation is not used or PINs are not available from your identity management 
service, then you can assign user PINs in two ways. The method to use depends on how 
much of the process you want your users to participate in.

Assigned by an Organization Administrator or User Administrator in the Account 
Management portal—Can be done manually, one user badge at a time, or by importing 
from a CSV file, for multiple user badges
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1.

Assigned by the user—Can be done manually from the user’s My Accounts page, which 
requires users to provide their PIN

PIN generation options Administrator User

Automatically generate and 
email

Can request Lexmark Cloud 
Services to generate a new 
PIN for users2

Can request Lexmark Cloud 
Services to generate a new 
PIN for themselves2

Administrator manually sets Can set or reset user PINs Must request a new PIN 
from an administrator1

User sets Cannot set or reset user 
PINs

Can set or reset their own 
PIN

1 Administrator applies to Organization Administrators and User Administrators.

2 PINs are sent to the user through email from Lexmark Cloud Services.

PINs assigned by an Organization Administrator or a User 
Administrator

An Organization Administrator or a User Administrator can set PINs for users one at a time 
or for multiple users at once by importing a file. New or reset pins are emailed to the user.

Note: Make sure that PIN Generating Options is set to either Automatically 
generate and email or Administrator manually sets.

Setting the PIN for a single user

The Organization Administrator or User Administrator can use one of the following 
methods to set or reset a PIN for a user:

Using the users list

From the Account Management portal, select the Users card, or click Users > Users.
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2.
3.

In the E‑mail column, click the user email.
In the Printer Login section, for the PIN login, click either Set PIN or Reset PIN.
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4.

▪

▪

▪

Based on the option chosen in the PIN Generation Option for the Organization Printer 
Login Configuration, do any of the following:

Note: The result of clicking Set PIN or Reset PIN depends upon the PIN 
Generation Option chosen for the Organization Printer Login Configuration 
page.

If Automatically generate and email is selected in the PIN Generation menu, 
then an email with the new PIN is sent as soon as you click Set PIN or Reset 
PIN.
If Administrator manually set is selected in the PIN Generation menu, then a 
user must submit a request outside of Lexmark Cloud Services to an 
Organization Administrator or a User Administrator to set or reset their PIN.
If User set is selected in the PIN Generation menu, then you can click Set PIN 
or Reset PIN, and then enter the new PIN, and then click Generate PIN.
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1.
2.
3.

An example of PIN received by the user.

Using Manage Badge/PIN

From the Account Management portal, click Users > Manage Badge/PIN.
Click the PINs tab.
Click Generate.
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4. In the E‑mail field, type the email address of the user, and then click Generate PIN.
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Note: The user receives an email with the PIN.

Importing user PINs

The Organization Administrator or User Administrator can set the PIN for one or more 
users by importing the PINs using a CSV or TXT file.

Notes

PINs can be imported when user accounts are created using the file import method.
If PIN Generation Options is set to Automatically generate and email, then any 
PINs set in the imported file are ignored. The PIN field should be left empty.
For more information on the CSV and the TXT file, see Lexmark Cloud Services 
Administrator's Guide.
The headers of the import file are case-sensitive.
Count the commas. All columns must be accounted for on each line of the import file.

The Organization Administrator or User Administrator can use one of the following file 
import methods to set or reset a PIN.
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2.
3.

4.

•

1.
2.
3.
4.
5.

•

◦

◦

•

Using the users list

From the Account Management portal, select the Users card, or click Users > Users.
Click Import.
In the Import Users window, browse to the CSV or the TXT file that contains the users 
list.
Click Import Users.

Note: The user receives an email with the PIN.

Using Manage Badge/PIN

From the Account Management portal, click Users > Manage Badge/PIN.
Click the PINs tab.
Click Import or Import PINs.
In the Import PINs window, browse to the CSV or the TXT file that contains the PINs.
Click Import PINs.

Note: The user receives an email with the PIN.

How PIN data in the imported file is used depends on the PIN generation options selected on 
the Printer Login Configuration page.

If the Automatically generate and email option is selected , then PIN values in the 
imported file are ignored. Lexmark Cloud Services automatically creates a PIN for 
each user in the file.
In the Administrator manually set option is selected , then users are assigned the PIN 
value associated with their entry in the imported file.

Setting PIN expiration

Administrators can select whether PINs will expire and how long before they expire by 
clicking Organization > Printer Login Configuration. If a PIN expires, then you must use 
one of the methods to reset the PIN. The PIN expiration and reset options depend on the 
selected PIN generation options.

Automatically generate and email—You cannot set an expiration for the PINs.
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◦

Administrator manually set or User set—You can set the PIN to never expire or to expire 
after 1 to 48 hours or 1 to 180 days.

PINs assigned by the user

Users can set or reset their PINs from their My Account page.

From the username menu, select My Account. In the Printer Login section, you can view 
following:

Set PIN
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◦

◦

•

•

Reset PIN

Check e-mail or contact administrator for your PIN

Note: If you do not currently have a PIN, then in the Printer Login section, click Set 
PIN. If you currently have a PIN, then click Reset PIN.

Setting and resetting the PIN

Depending on the selected PIN generation option, clicking Set PIN or Reset PIN results in 
either of the following

If PIN Generation Options is set to Automatically generate and e-mail, then Lexmark 
Cloud Services generates and emails a new PIN to the user.
If PIN Generation Options is set to User set, then users are allowed to manually set or reset 
their PINs. They can do this task by entering a PIN with the required number of digits, and 
then clicking Generate PIN.
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1.

2.

Note: If “Check e-mail or contact admin for your PIN” appears, then it means that 
PIN generation is manually set by the administrator. To set or reset their PIN, users 
must submit a request outside of Lexmark Cloud Services to an Organization 
Administrator or a User Administrator.

Modifying user information

If Identity Federation is used, then user information is retrieved from your authentication 
provider through claims. Any changes made to this data in Lexmark Cloud Services are 
overwritten when the user logs in for the next time.
If Identity Federation is not used, or if claims from your authentication provider do not work, 
then modify user information by doing one of the following:
Manually modify user information in the Account Management portal

From the Account Management portal, select the Users card or click Users > Users.

In the E‑mail column, click the user email.
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3.

4.

In the Personal Information section, click Edit.

In the Personal Information page, enter the information, and then click Update Profile.
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Import changes to user information using a CSV file

Use this method if you want to modify multiple user accounts simultaneously. The Import 
feature lets you create, update, and delete multiple users in an organization using a CSV 
or TXT file. You can also create user groups, and then assign a user to those groups. For 
more information, see "Managing users" topic in Lexmark Cloud Services Administrator's 
Guide.

When importing, note the following:

Use the UPDATE command to modify the information of an existing user account.
The headers of the import file are case‑sensitive.
Count the commas. All columns must be accounted for each line of the CSV file.
The size of the CSV file must not exceed 1MB.

Deleting user accounts

If Identity Federation is used, then a user’s account can only be permanently deleted from 
your authentication provider. A user account that is deleted only from Lexmark Cloud 
Services is restored when the user logs in the next time.
If Identity Federation is not used, then you can delete user accounts by doing one of the 
following:
Manually delete the user account in the Account Management portal
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1.

2.

3.

From the Account Management portal, select the Users card or click Users > Users.

Select the user, and then click Delete.

Click Delete User.
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1.

2.

Delete user information by importing a file in the Account Management portal

For more information, see "Managing users" in Lexmark Cloud Services Administrator's 
Guide.

Enroll your printers

Fleet Management roles

The Fleet Management Administrator and File Service Administrator roles must be 
assigned to users who access the Fleet Management portal and enroll and manage 
printers

Note: You must have the User Administrator or Organization Administrator role to 
assign these roles to users.

Fleet Management roles for channel partners

Channel partners who manage printers in their customers’ organizations must be members 
of a Child Organization Access Group. The group must have the Fleet Management 
Administrator and File Service Administrator roles assigned to it.

Notes

You must have the User Administrator or Organization Administrator role to create 
and manage Child Organization Access Groups.
Roles assigned through membership in a Child Organization Access Group apply 
across all customer organizations.

Creating Child Organization Access Groups

From the Account Management portal, click Groups tab.

Click the Child Organization Access tab.
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3.

4.
5.
6.

7.
8.
9.

Click Create.

In the Group name field, type the name of the group, and then click Create Group.
Click the name of the group.
Click Add or Add Members.

Select one or more members, and then click Add Members.
Click the Group Roles tab.
Click Assign.

Note: By default, the Partner Administrator role is assigned to all Child Organization 
Access Groups.
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10. From the Custom Roles list, select Fleet Management Administrator and File Service 
Administrator roles, and then click Assign Roles.
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Selecting an agent

The first step in enrolling printers is to decide which agent or agents to use. You may 
choose from the Native Agent, Fleet Agent, Printer Agent, or Local Agent.

Note: Collectively, the agents are referred to as Cloud Bridge.
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Native Agent

The Native Agent is built into the printer firmware. It is available on all current‑generation 
Lexmark printers. The control panel on current‑generation Lexmark printers has a dark 
background.

Sample of the control panel from a current‑generation printer that supports the Native 
Agent.

Requires firmware 081.215 or later is required. For more information, see "Viewing the 
printer firmware version" topic in Lexmark Cloud Services Administrator's Guide.
Supports data collection and configuration on all current generation printers.
Supports the deployment of eSF applications on current generation, touch-screen printers. 
For more information, see "Supported printer models" topic in Lexmark Cloud Services 
Administrator's Guide.
Native Agent–capable printers can be enrolled using the following methods:

Cloud-based pre-enrollment
Printer-based enrollment
Printer Enrollment Tool (PET)

Requires the printers to have a constant Internet connection.
Uses Internet of Things (IoT) technology to reports printer data to the cloud.

Fleet Agent

The Fleet Agent is an application that is configured and installed on an on‑site server or 
host computer. It enrolls Lexmark and third-party printers to the Lexmark Cloud Services.

Uses Internet of Things (IoT) technology to report printer data to the cloud.
Requires a stable, high-availability server or host computer with a constant Internet 
connection and with the following minimum specifications:

Operating system x86, x64-bit or Linux 64-bit

Processor 1Ghz dual‑core

RAM 2GB
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Storage 32GB (Fleet Agent requires 12GB of 
storage)

Supports printer configuration and data collection with Lexmark printers. For more 
information, see "Supported printer models" topic in  Lexmark Cloud Services Administrator's 
Guide. Data collected and printer configuration capabilities may vary by model.
Data is collected over Simple Network Management Protocol (SNMP) from the public and 
private printer MIBs available on the enrolled printers.
Supports data collection for some third-party printers. Data collected varies by manufacturer 
and model.

Printer Agent

Printer Agent

The Printer Agent, also referred to as embedded agent, uses an embedded application, 
the Printer Configuration Agent (PCA), installed on each Lexmark printer. The Printer 
Configuration Agent collects and sends the printer information to Lexmark Cloud Services.

Requires running the Printer Enrollment Tool on a network connected computer to discover 
and enroll printers.
Supports data collection and configuration on Lexmark touch-screen printers with eSF 
version 3.0 or later. For more information, see "Supported printer models" topic in  Lexmark 
Cloud Services Administrator's Guide.
Requires the printers to have a constant Internet connection.
Uses Internet of Things (IoT) technology to report asset inventory (meters, counters, and 
supplies) data. If the IoT hosts are blocked during enrollment, then this agent reverts to the 
https path.

Local Agent

Local Agent

The Local Agent is an application configured and installed on a Windows computer system 
that has USB-attached printers. It enrolls locally attached Lexmark printers into Lexmark 
Cloud Services. It uses an Internet of Things (IoT) connection to communicate with 
Lexmark Cloud Services.

Automatically discovers and enrolls USB-connected, Lexmark printers.
Uses Internet of Things (IoT) technology to report asset inventory (meters, counters, and 
supplies) data.
Supports Windows 64‑bit and 32-bit operating systems.

Comparing agents

To make sure that you have an optimal experience in enrolling and managing your print 
fleet, select the correct agent for your specific needs.

If managing a current‑generation Lexmark touch‑screen printer with eSF version 5.0 or later, 
then use the Native Agent, Fleet Agent, or Printer Agent.
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If managing Lexmark touch‑screen printers with eSF version 3.0 or later, then use either the 
Printer Agent or the Fleet Agent.
If managing a group of touch‑screen and non-touch‑screen Lexmark printers, then use the 
Fleet Agent.
If managing a group of Lexmark and third-party printers, then use the Fleet Agent.
If managing USB-connected Lexmark printers, then use the Local Agent.
If eSF applications cannot be installed on the printers to be managed, then use the Fleet 
Agent.
If an on‑site server or host computer cannot be used, then use either the Printer Agent or the 
Native Agent.
All agents may be used in the same organization at the same time.
A printer can only be managed by one agent.

Scenario Native Agent Fleet Agent Printer Agent Local Agent

Uses an agent 
native to 
printer 
firmware

✔ X X X

Uses an 
application 
running on an 
Internet‑connected, 
on‑site server 
or host 
computer

X ✔ x X

Uses an 
embedded 
application 
running on 
enrolled 
printers

X X ✔ X

Supports USB- 
connected 
printers

X X X ✔

Internet 
connection 
required for 
printers

✔ ✔ ✔ X

Uses Internet 
of Things (IoT) 
technology

✔1 ✔3 ✔2 ✔2

Supports data 
collection and 
configuration 
in Lexmark 
printers with 
eSF version 
5.0 or later 
(touch‑screen 
models)

✔4 ✔4 ✔4 X
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Scenario Native Agent Fleet Agent Printer Agent Local Agent

Supports data 
collection and 
configuration 
in Lexmark 
printers with 
eSF version 
3.0 
(touch‑screen 
models)

X ✔4 ✔4 X

Supports data 
collection and 
configuration 
for Lexmark 
printers with 
eSF version 
2.0

X ✔4 X X

Supports data 
collection for 
non-eSF 
Lexmark 
printers

✔4 ✔4 X ✔5

Supports data 
collection from 
third‑party 
printers

X ✔ X X

Requires a 
user account 
on the printer 
with 
administrative 
access

X X ✔ X

Performs data 
collection over 
SNMP

X ✔ X X

1 All printer-cloud communications use IoT. IoT support is resident in the printer firmware.

2 IoT default communications path for asset inventory (meters and counters) data. If IoT 
connection cannot be established, then an https path is supported.

3 All cloud communications use IoT.

4 For more information, see "Supported printer models" topic in  Lexmark Cloud Services 
Administrator's Guide.

5 When the printer is connected to a workstation through USB.
Before enrolling

To make sure that the enrollment of printers is successful, do the following::
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◦

•

•

Make sure that the printer to be enrolled supports the agent to be used. For more 
information, see "Supported printer models" topic in  Lexmark Cloud Services Administrator's 
Guide.
If a firewall or proxy is used, then add the proper host names to the Allow List.
If the printer was previously used at another customer site, then unenroll the printer from its 
current organization in the Cloud Fleet Management portal. If necessary, also erase the 
printer memory.

When erasing printer memory, note the following:

Unenrolling must be performed the first time a printer is enrolled with a customer.
Any configuration settings or customer data related to a prior installation is deleted. 
For more information, see Erasing printer memory.

Make sure that all printers are online and in the Ready state with no unresolved errors, such 
as paper jams or incorrect email configurations.
The printer firmware is updated to the latest recommended version.
Printer permissions are set correctly.
Printer login credentials for secure printers are available.
Printer SNMP configurations are available.

When using the Fleet Agent, SNMP v3 must be enabled on eTask version 5.0 and 
higher printers.
By default, SNMP v3 must be enabled on these models.
SNMP v3 does not have to be configured. It must be enabled.

Make sure that Firewall, DHCP, and DNS settings are correct.
The date and time are configured correctly, preferably using a network time protocol server.
If possible, enroll printers during off hours when the printers are not being used.

Firmware and configuration deployments from Cloud Fleet Management following 
enrollment may briefly take the printer offline.

Using the Native Agent

Enrolling printers with Native Agent

The Native Agent is available on all current‑generation Lexmark printers that are Internet 
of Things (IoT)–capable. It is built into the firmware for any printer running firmware version 
075.272 or later. The Native Agent can be used to enroll Lexmark printers in Lexmark 
Cloud Services. No applications are required to be installed on the printer or to run on an 
on-premises server or hosted computer. The printer must have a constant Internet 
connection. For more information on supported models, see "Supported printer models" 
topic in Lexmark Cloud Services Administrator's Guide.
You can enroll printers with the Native Agent using the Printer Enrollment Tool (PET), 
cloud-based pre-enrollment, or printer-based enrollment.

Printer Enrollment Tool—Can be used to enroll any current‑generation IoT-capable 
Lexmark printers. If you are unable to enroll the printer using the Cloud-based pre-enrollment 
or printer-based enrollment methods, then PET must be used.
Cloud‑based pre‑enrollment—Lets you specify Lexmark printers that you want to enroll. In 
this process, you enter an enrollment code at the printer. The enrollment code is obtained 
from the Fleet Management portal for an organization and can be used to enroll all pre- 
enrolled printers for that organization. The list of pre-enrolled printers can be entered one at 
a time or imported from a CSV or TXT file before going on-site. This method is useful for 
large printer deployments because you can perform much of the needed work in advance.

https://support.lexmark.com/en_us/printers/printer/MX421/article/v49278774/erasing-printer-memory.html
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4.

◦

Printer‑based pre‑enrollment—Lets you initiate the enrollment at the printer. You obtain an 
enrollment code from the printer and enter it in the Fleet Management portal. This method is 
useful if you are deploying only a few printers or do not know in advance the serial numbers 
of the printers to be deployed.

Enrolling printers using the Printer Enrollment Tool

The Printer Enrollment Tool (PET) can be used to enroll any current‑generation IoT- 
capable Lexmark printers with the Native Agent. Use this method when enrolling older 
models of the current‑generation printers or if you cannot enroll printers using the cloud- 
based pre-enrollment or printer-based enrollment methods.
Downloading the Printer Enrollment Tool

If you do not have a copy of the PET, download it from the Cloud Fleet Management portal.

From the Fleet Management web portal, do one of the following:

If some printers are already enrolled, then click Printers > Enroll Printer using > 
Printer Agent > Download PET.
If enrolling printers for the first time, then click Use Printer Agent > Download PET.

Accept and download the End User License Agreement (EULA).
Extract the compressed folder.

Using the Printer Enrollment Tool

Run the Printer Enrollment Tool launcher.
Log in using the same email address and password used to connect to the Cloud Fleet 
Management portal.

Note: If a newer version of the PET is available, then you will be prompted to 
download it.

If you manage multiple organizations, then select the organization, and then click Next. 

Click  on the upper‑right corner of the page, and then configure the following:

Discover and enroll native agent-capable printers using—Determines whether 
Native Agent-capable printers are enrolled using the Native Agent or Printer Agent.
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◦

◦
◦

5.

Time out for Printer Discovery—Determines how long the PET waits for a response 
to each network broadcast. The value can be increased to improve printer discovery in 
slow networks.
Time out for Printer Enrollment—Determines how long the PET waits for the Printer 
Agent to enroll the printer. The value can be increased to improve the printer 
enrollment process of older printers.
Logging detail levels—Set the logging level to Detailed.
SNMP settings—The SNMP settings in the PET must match those of the printers to 
be discovered.

Note: Printer discovery first occurs using mDNS, and then by Simple Network 
Management Protocol (SNMP). If SNMP discovery is desired, then mDNS 
must be disabled on the printers.

From the Discovery Type menu, select any of the following:
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Search local network—Finds all printers on your local subnet. Use this method if you 
have several printers on the subnet but you do not know their network parameters. 
This method may take several minutes to complete.
Advanced search—Lets you refine the search by specifying network parameters to 
find printers. Use this method if you have a small number of printers or if the network 
parameters of the printers are known. This method is usually faster than the Search 
local network method.

The following are the network parameters:

Specific IP address
Subnet
Range
Fully qualified domain name (FQDN)

Notes
To discover printers successfully, make sure that mDNS is enabled on the 
printer or that the SNMP configurations of the PET and the printers match.
Printers in the Eligible to Enroll tab can be enrolled with the Native Agent if 
their agent type is set to Native. 
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Select one or more printers to enroll, and then click Enroll Printers.

Note: The selected printers do not have to be of the same agent type. Each selected 
printer is enrolled using the indicated agent type.

If necessary, log in to access the printer Embedded Web Server, and then click Apply 
Credentials. Otherwise, click Skip This Step.

Note: Login credentials can be applied to limit access to printer settings to 
authorized individuals only.

Cloud‑based pre‑enrollment

Cloud-based Native Agent pre-enrollment lets you specify in advance the Lexmark printers 
that you want to enroll. You only need to enter an enrollment code at the printer. The 
enrollment code is obtained from the Fleet Management portal for an organization and can 
be used to enroll all pre-enrolled printers for that organization. The list of pre-enrolled 
printers can be entered one at a time or imported from a CSV or TXT file. This method is 
useful for large printer deployments.
Pre‑enroll printers by doing the following:

Entering their serial number in the Cloud Fleet Management portal
Obtaining the organization’s enrollment code
Applying the organization’s enrollment code to the printer, using the control panel or the 
Embedded Web Server (EWS)

Note: Cloud-based pre-enrollment is supported only in current‑generation IoT- 
capable Lexmark printers. If enrollment using this method is unsuccessful, then 
enroll using the Printer Enrollment Tool.

Entering printer serial numbers in the Cloud Fleet Management portal

printer-serial-number2

From the Fleet Management web portal, do one of the following:
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If some printers are already enrolled, then click Agents > Native Agents > 
Enrollment > Pre‑enroll > Pre‑enroll printers.

If enrolling printers for the first time, then click Agents > Native Agents > Pre‑enroll 
Printers.

From the Pre‑enroll Printers dialog, do one of the following:

Select Manually input serial number, type the printer serial number, and then press 
Enter.
Select Import printer serial number from file, and then browse to the CSV or TXT 
file.
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Note: To receive the enrollment code and the complete enrollment instructions using 
email, type your email address.

Once pre-enrolled, the printer serial number is listed on the Native Agent page with a 
Printer pre-enrolled icon.

Obtaining the enrollment code

Click Agents > Native Agents > Enrollment > Pre‑enroll.

Copy the organization’s enrollment code.
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Note: You can also obtain the enrollment code by clicking the pre‑enrolled serial 
number. The code can be found in the Printer Information section. 

Note: If the Enrollment menu is not visible, or there are no printer serial numbers 
listed, then no printers have been pre-enrolled. For more information, see 
Printer‑based enrollment on page 73.

Applying the enrollment code to the printer

Using the control panel

From the printer home screen, touch Settings > Cloud Services > Cloud Services 
Enrollment
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From the Enable communication with Lexmark Cloud Services menu, touch On.
Touch Enroll Printer, and then enter the enrollment code.

Touch OK
Using the Embedded Web Server

From the Embedded Web Server, click Settings > Cloud Services > Cloud Services 
Enrollment
Select Enable communication with Lexmark Cloud Services, and then click Save.
Click Refresh until the Enrollment Code field is visible. This may take a few minutes.
In the Enrollment Code field, enter the enrollment code, and then click Enroll Printer.

Notes
The enrollment code is case-sensitive.
The enrollment can be verified from the Cloud Fleet Management portal.
It may take a few minutes for the printer enroll.
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Printer‑based enrollment

Printer-based enrollment begins at the printer. You obtained an enrollment code from the 
printer, and enter it in the Fleet Management portal. This method is useful if you plan to 
only deploy a few printers or if you are unaware of the printer’s serial number.
Printer-based enrollment involves:

Obtaining the printer’s enrollment code.

Note: This is done from the printer control panel or using its Embedded Web Server 
(EWS).

Entering the printer’s enrollment code in the Cloud Fleet Management portal.

Note: The printer-based enrollment method is only supported for current 
generation Lexmark IoT-capable printers. If enrollment using this method is 
unsuccessful, then enroll using the Printer Enrollment Tool.

Obtaining the enrollment code

There are two methods for obtaining the printer enrollment code.

Using the control panel of the printer
Using the Embedded Web Server

Obtaining enrollment code by using the control panel

From the printer home screen, touch Settings > Cloud Services > Cloud Services 
Enrollment

From the Enable communication with Lexmark Cloud Services menu, touch On.
From the Get Enrollment Code menu, touch Get Code, copy the enrollment code, and then 
touch OK.
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◦

Obtaining the enrollment code by using the Embedded Web Server

From the Embedded Web Server, click Settings > Cloud Services > Cloud Services 
Enrollment.
Select Enable communication with Lexmark Cloud Services, and then click Save.
Click Refresh until the Get Enrollment Code is enabled. This may take a few minutes.
Click Get Enrollment Code, and then take note of the code.

Entering printer serial numbers in the Cloud Fleet Management portal

printer-serial-number

From the Fleet Management web portal, do one of the following:

If no devices are enrolled:

Click Agents > Native Agents > Enroll Printer.
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If devices are already enrolled:

Click Agents > Native Agents > Enrollment > Enroll Printer.
Enter the enrollment code, and click Enroll Printer.

Note: The enrollment code is case-sensitive.

Note: In case of invalid code, you will get an error message. 

Using the Fleet Agent

Creating a Fleet Agent

Before using Fleet Agent, you must create an agent and establish settings that work best 
for your environment.

From the Fleet Management portal, click Agents > Fleet Agents > Create Fleet Agent.
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In the Create Fleet Agent form, configure the following:

General—Type a name and description for the Fleet Agent.
Discovery Criteria and Settings:

Discovery criteria:

Transfer management of discovered printers that are already through 
another agent—Transfer all discovered printers that are already enrolled 
under another agent to this Fleet Agent. If not selected, then discovered 
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printers that are already enrolled under another agent will remain enrolled 
under their current agent.

Note: Prevent overlapping Discovery Criteria between Fleet 
Agents. Overlapping criteria cause printers to switch between 
Fleet Agents.

Search Type—Select the type of discovery to be done.

Search Local Network—Search the local network subnet for 
printers. If the printers to be discovered have SNMP configured, 
then a matching SNMP profile must be added to the Fleet Agent 
configuration.

Note: The Fleet Agent discovers only printers that match its 
SNMP profile.

Advanced Search—Search or exclude printers by specific IP 
address, subnet, range, and fully qualified domain name (FQDN). If 
the printers to be discovered have SNMP configured, then a 
matching SNMP profile must be added to the Fleet Agent 
configuration.

You can click Add Discovery Criteria to Include to enter the 
search criteria and select an SNMP profile. Repeat the 
process for each search criteria. After adding the search 
criteria, click Add Discovery Criteria.
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Notes
The Fleet Agent discovers only printers that 
match its SNMP profile.
If printers in the search criteria have different 
SNMP configurations, then the search criteria 
can be entered multiple times, each with a 
different SNMP profile.
A printer can be managed by only one agent. 
Care must taken when defining the Printer 
Discovery settings when using Native Agent, a 
Printer Agent, and a Fleet Agent, or multiple 
Fleet Agents within the same organization. If 
overlapping Printer Discovery criteria exist, then 
printers may not be managed by the intended 
agent. The printer data may roll up under the 
wrong agent and may appear to unenroll and 
re-enroll continually.

You can click Import or Export to import or export functions 
to use predefined search criteria or saved search criteria for 
later use.

SNMP Profile—Can be created to match the SNMP configuration of printers 
discoverable by the Fleet Agent. You can click Create to create profiles. Profiles 
can be created based on SNMP v1, v2c, or v3. The SNMP profile created and 
used by a Fleet Agent must match the SNMP configuration of the printers that 
the Fleet Agent manages.
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Notes
The Fleet Agent discovers printers that match its SNMP profile.
An SNMP profile using SNMP v3 is not required by the Fleet 
Agent. However, SNMP v3 must be enabled on eSF version 5 or 
later printers released since 2016. An SNMP v3 profile does not 
need to be configured on these printers, but SNMP v3 must be 
enabled. If you do not enable SNMP v3, then the Fleet Agent 
cannot update firmware, applications, and configurations.

Scheduled Tasks—Set up the Fleet Agent to periodically rediscover printers 
and to refresh printer information. Setting a discovery interval lets you 
automatically add or remove printers as they are added, exchanged, or 
removed.
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Printer Discovery Task—Set the Fleet Agent to rediscover and enroll 
printers on a regular basis or only when manually directed from the Cloud 
Fleet Management portal.

None (Run tasks manually only)—Run manually.
Once a day—Set a specific time.
Once a week—Set a specific time on a selected day of the week.
Once a month—Set a specific time on the last day of the month or 
on a selected day of the month.

Refresh Printer Information Task—Set the Fleet Agent to refresh printer 
information at certain intervals.

Every 15 minutes
Every 30 minutes
Every hour
Every 2 hours
Every 6 hours
Every 12 hours
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3.

Notes
The default setting is 1 hour. A shorter interval provides a 
more current printer status but puts more traffic on the local 
network. A longer interval reduces the local network traffic, 
but provides a slower printer status update.
The Fleet Agent reports printer information to the Fleet 
Management services if a page count change occurs. It also 
reports or when a printer or supplies alert has been 
detected.

Other Settings

Log level—Set the level of detail provided when a log is run for the Fleet 
Agent. Always set the log level to Detailed.

Message Type Summary Detailed

Error ✔ ✔

Warn ✔ ✔

Informational ✔ ✔

Debug X ✔

Network utilization delay (milliseconds)—Limit the network traffic 
caused by the Fleet Agent printer discovery process. A higher number 
reduces the impact on network performance but makes the discovery 
process longer. The default delay setting is 250 milliseconds. The delay 
must not be set to zero.

Click Create Agent.

Installing a Fleet Agent

Fleet Agent installation package

After creating a Fleet Agent, install it on a server or host computer within the customer’s 
network. The Fleet Agent installation package can be downloaded or provided through a 
link emailed from the Cloud Fleet Management portal.
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Note: The size of the installation package is about 140MB.

Fleet Agent activation code

You need an activation code during setup of the Fleet Agent. You can obtain the code by 
clicking the Generate activation code link. The code registers the installed Fleet Agent 
with a Fleet Agent definition. You can associate a Fleet Agent definition with only a single 
Fleet Agent installation. If the code is not used within 72 hours, then you must generate a 
new code.
Installing and activating a Fleet Agent

From a server or host computer, run the Fleet Agent installation package.
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Accept the End-User License Agreement (EULA).
Enter the port number.

Notes
The default port number is 80.
If port 80 is not available, then enter any available port, such as 8080 or 8088.

Click Finish to close the installation window, and launch the Fleet Agent on a web browser.
Enter the Fleet Agent's Activation Code, and then click Continue.
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Notes

A proxy can be set.
You can apply a password to restrict access to the Fleet Agent.
You can also set the initial printer discovery and enrollment to be performed 
automatically after the Fleet Agent is activated. 
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After activation, the Fleet Agent details page shows its status as Communicating. 

Using a proxy with the Fleet Agent

Sometimes you must change the proxy configuration after the Fleet Agent is installed. To 
change the proxy configuration, do the following:

Open a web browser, and then type https://localhost:<portnumber> .

Note: <portnumber> is the port used when the Fleet Agent was installed. The default 
port number is 80.

Click  on the upper‑right corner of the Fleet Agent home screen to access the Proxy 
Configuration settings.
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Click Verify Proxy Settings.

Discovering and enrolling printers

To manually initiate the printer discovery and enrollment process, click Discover & Enroll 
Printers on the Fleet Agent details page in the Fleet Management portal.
A Discover printers task is created on the Fleet Agent task queue. Discovered and enrolled 
printers appear on the Printers page in the Fleet Management portal.
The initial discovery and enrollment task can be done manually or as part of the Fleet Agent 
activation process. Afterward, the task is automatically repeated on the schedule that you set 
when creating the Fleet Agent. For more information on installing and activating a Fleet 
Agent, see Installing a Fleet Agent on page 81.
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Printers not being discovered

You can use a MIB walk to determine why a printer is not being discovered. You can obtain 
a MIB walk log from the Cloud Fleet Management portal, and then contact Customer 
Support Center to review the log. To initiate a MIB walk, do the following:

From the Fleet Management web portal, click Agents > Fleet Agents.
Click the Fleet Agent name.
In the Log section, type the IP address of the printer, and then click Request.

Click Download.

Managing an installed Fleet Agent

After a Fleet Agent is installed, you may need to change it for the following reasons:

Printer discovery parameters
Task scheduling
Version update for the Fleet Agent or the Printer Support Library
Deactivated or deleted Fleet Agent

Editing a Fleet Agent
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From the Fleet Management web portal, click Agents > Fleet Agents.
Click the Fleet Agent name.
Click Edit Agent.
Click Save Changes.

Notes

Changes made to the definition of an existing Fleet Agent take effect immediately.
If the SNMP profile of a Fleet Agent definition is changed or deleted, then all printers 
associated with that profile are unenrolled and no longer discoverable by this Fleet 
Agent.
After a Fleet Agent is updated, you can initiate a Discover printer task in the Fleet 
Agent details page by clicking Discover & Enroll Printers. This task discovers and 
enrolls printers based on the updated Fleet Agent definition.

Updating a Fleet Agent

Available updates to the Fleet Agent executable file or for Printer Support Library used by 
the Fleet Agent appear on the Fleet Agents page.

From the Fleet Management web portal, click Agents > Fleet Agents.
Select one or more Fleet Agents, and then click Update > Fleet Agent.

Click Continue.

Deactivating a Fleet Agent

Deactivating a Fleet Agent stops it from collecting printer data. After it is deactivated, you 
can no longer manage printers associated with that Fleet Agent. Printers associated with 
the deactivated Fleet Agent are unenrolled and no longer appear on the Printers page. The 
Fleet Agent definition is not deleted. Device data associated with the deactivated Fleet 
Agent is also retained.

From the Fleet Management web portal, click Agents > Fleet Agents.
Click the Fleet Agent name.
Click More > Deactivate Agent.
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Click Deactivate Agent.

Restoring a deactivated Fleet Agent

From the Fleet Management web portal, click Agents > Fleet Agents.
Click the Fleet Agent name.
In the Status section, click Generate activate code.
Copy the activation code.
Launch the Fleet Agent on a web browser, and then enter the activation code.
Click Continue > Activate Agent.
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Note: Once the Fleet Agent has been reactivated, you must initiate the Discover & 
Enroll Printers task from the Cloud Fleet Management portal. This restores the data 
collection and printer management functions of the Fleet Agent.

Deleting a Fleet Agent

If a Fleet Agent installation is no longer required at a customer location, it must be deleted. 
Deleting a Fleet Agent removes the Fleet Agent definition from the Cloud Fleet 
Management portal. It also unenrolls any printers associated with the deleted Fleet Agent, 
and deletes any data associated with those printers. The Fleet Agent executable running in 
the customer’s environment will not be uninstalled. You must uninstall the Fleet Agent 
executable manually.

From the Fleet Management web portal, click Agents > Fleet Agents.
Click the Fleet Agent name.
Click More > Delete Agent.

Click Continue.
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Notes

A deleted Fleet Agent cannot be restored.
A new Fleet Agent definition must be created. Once created, a new activation code 
for the definition can be applied to the Fleet Agent executable, if it was not manually 
uninstalled.
For more information, see Installing a Fleet Agent on page 81.

Using the Printer Agent

Using a Printer Agent

Downloading the Printer Enrollment Tool

If you do not have a copy of the Printer Enrollment Tool (PET), download it from the Cloud 
Fleet Management portal.

From the Fleet Management web portal, do one of the following:

If some printers are already enrolled, then click Printers > Enroll Printer using > 
Printer Agent > Download PET.
If enrolling printers for the first time, then click Use Printer Agent > Download PET.

To accept the End User License Agreement (EULA) and download, click Accept and 
Download.
Extract the compressed folder.

Using the Printer Enrollment Tool

Run the Printer Enrollment Tool launcher.
Log in using the same email address and password used to connect to the Cloud Fleet 
Management portal.

Note: If a newer version of the PET is available, then you will be prompted to 
download it.
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If you manage multiple organizations, then select an organization, and then click Next.

Click  on the upper‑right corner of the page, and then configure the following:

Discover and enroll native agent-capable printers using—Determines whether 
Native Agent-capable printers are enrolled using the Native Agent or Printer Agent.
Time out for Printer Discovery—Determines how long the PET waits for a response 
to each network broadcast. The value can be increased to improve printer discovery in 
slow networks.
Time out for Printer Enrollment—Determines how long the PET waits for the Printer 
Agent to enroll the printer. The value can be increased to improve the printer 
enrollment process of older printers.
Logging detail levels—Set the logging level to Detailed.
SNMP settings—The SNMP settings in the PET must match those of the printers to 
be discovered.

Note: Printer discovery first occurs using mDNS, and then by Simple Network 
Management Protocol (SNMP). If SNMP discovery is preferred, then mDNS 
must be disabled on the printers.
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From the Discovery Type menu, select any of the following:

Search local network—Finds all printers on your local subnet. Use this method if you 
have several printers on the subnet but you do not know their network 
parameters. This method may take several minutes to locate complete.
Advanced search—Lets you refine the search by specifying network parameters to 
find printers. Use this method if you have a small number of printers or if the network 
parameters of the printers are known. This method is usually faster than the Search 
local network method.

The following are the network parameters:

Specific IP address
Subnet
Range
Fully qualified domain name (FQDN)

Notes
To discover printers successfully, make sure that mDNS is enabled on the 
printer or that the SNMP configurations of the PET and the printers match.
Printers in the Eligible to Enroll tab can be enrolled with the Native Agent if 
their agent type is set to Native.

Select one or more printers to enroll, and then click Enroll Printers.
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Note: The selected printers do not have to be of the same agent type. Each selected 
printer is enrolled using the indicated agent type.

If necessary, log in to access the printer Embedded Web Server, and then click Apply 
Credentials. Otherwise, click Skip This Step.

Notes
When using a Native Agent or Printer Agent and a Fleet Agent, or multiple 
Fleet Agents within the same organization, care must taken while defining the 
Printer Discovery settings. Only one agent can manage a printer. If 
overlapping Printer Discovery criteria exist, then printers may not be managed 
by the intended agent.
The enrollment process may take several minutes to complete.
After successful enrollment, wait several minutes for the printers to appear in 
the Cloud Fleet Management printers list.
When a printer is enrolled using the Printer Agent, the PET installs an 
embedded (eSF) application, called the Printer Configuration Agent (PCA), on 
the printer. The PCA is the communications path between the printer and the 
cloud.

Verifying the printer enrollment status

After running the PET to enroll printers, do the following to verify that an enrolled printer 
can communicate with Cloud Fleet Management. For more information on troubleshooting, 
see "Fleet Management troubleshooting" group in Lexmark Cloud Services Administrator's 
Guide.

Check for printer enrollment failures in the PET.

For security-related failures, re‑enroll printers using the correct security credentials.

If the printer date and time are not correct, then an error message appears.

Make sure that the printer firmware is at least at the minimum recommended level.
Verify that embedded applications appear on the printer Embedded Web Server (EWS) 
application page.

If no applications appear, then power cycle the printer.
If the issue persists, then re‑enroll the printer.

Verify that the PCA embedded application is enabled or running on the printer. If the PCA is 
disabled or stopped, then enable or start it.
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Verify that the PCA application status is enrolled.

Open the Printer Configuration Agent application from the printer EWS. If the PCA 
status is unenrolled, then re‑enroll the printer.

Click Test Agent Connection to verify that the network and credential settings are 
correct.

Verifying the connection status after placing the printer in service

Do the following to verify the Cloud Fleet Management connection status of a printer after 
it is placed in service or its network environment is changed. For more troubleshooting 
information, see "Fleet Management troubleshooting" group in  Lexmark Cloud Services 
Administrator's Guide.

Click Test Agent Connection to verify that the network and credential settings are correct.
On e‑Task v5 or later printers, do the following:

When editing contacts in the printer address book, do not modify or delete the 
Lexmark_PCA_User entry.
When importing or applying the contactmanager.xml file, edit the contactmanager.xml 
file to set <addressbook clear=”false”>.

On the Cloud Fleet Management portal Printers page, do the following:

Verify that the printer is listed. If it is not, then re‑enroll the printer.
Check the communication status of the printer.

If it is Communicating, then verify communications by going to the Printer Details 
page clicking Refresh Printer Information, and then checking the status in 
Task History.

If it is Not communicating, then do the following:

Verify that the printer is in service and has network connectivity. Open the 
Printer Configuration Agent application from the EWS, and then click Test 
Agent Connection to verify that the network and credential settings are 
correct.
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Verify that the printer is in service in this organization. If the printer that 
you are enrolling was previously enrolled in another organization, then its 
Communication status will be Not communicating in the previous 
organization. To prevent this scenario, unenroll printers that are being 
moved to a new organization.
Re‑enroll the printer, in any of the following cases:

The application status of the PCA is unenrolled.
The printer security login has changed since the printer was 
enrolled.
The Lexmark_PCA_User account has been modified in any e‑Task 
v5 or later printers.
The printer DHCP/DNS configuration has changed or does not 
match the customer’s environment.
The printer date and time settings are not correct.

If a firewall is being used, then verify that the appropriate Lexmark Cloud 
Services URLs have been added to the Allow List. For more information, 
see "Deployment readiness checklist" in Lexmark Cloud Services 
Administrator's Guide.

If “Agent needs credentials” appears, then the agent is communicating with Cloud 
Fleet Management, but administrator credentials have been applied to the printers 
after enrollment. A lock symbol appears in front of the IP addresses of these printers.

You can apply credentials from the Cloud Fleet Management portal. For more 
information, see "Managing enrolled printers" group in Lexmark Cloud Services 
Administrator's Guide. You can also apply credentials by opening the Printer 
Configuration Agent eSF application and then clicking Update Credentials.
If “gent not communicating” appears, then the Fleet Agent associated with the printer 
is no longer communicating with Cloud Fleet Management. Verify that the Fleet Agent 
is still running and that it has a constant Internet connection.

If a firewall is being used, then verify that the appropriate Lexmark Cloud Services 
URLs have been added to the Allow List. For more information, see "Deployment 
readiness checklist" in Lexmark Cloud Services Administrator's Guide.

Setting the correct date and time

The printer date and time must be set correctly to avoid failures in printer enrollment or in 
the processing of Cloud Fleet Management tasks. If it is not set correctly, then printer 
enrollment or the processing of Cloud Fleet Management tasks may fail. It is best to 
configure the printer’s date and time by enabling the use of a Network Time Protocol (NTP) 
server. NTP servers are usually available from domain servers. Publicly available NTP 
servers can be found through an internet search.

If the printer’s date and time are not correct when it is enrolled, then the printer’s date and 
time will be set to the date and time of the Printer Enrollment Tool (PET) workstation if:

The Enable NTP is not selected
The Enable NTP is selected and the NTP Server address is blank
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Managing user accounts and printer permissions

To use and manage the Printer Agent, you must set the function access controls (FACs) 
and maintain an administrator account on the current‑generation Lexmark printers. When 
referring to the Printer Agent on printers, the printers can be Secured or Open.

e‑Task version 5 or later printers

Printers with e‑Task version 5 or later have a dark control panel background.

Secured Printers

If access to the Embedded Web Server (EWS) is protected, then provide the credentials in 
the Printer Enrollment Tool during enrollment.

The following permissions must be enabled in either the Public or All Users permissions 
groups to avoid a failed enrollment.

Access Control menu section Access control to enable

Administration Menus Security Menu



Rollout Guide

98

Access Control menu section Access control to enable

Device Management Remote Management

Open Printers

If access to the Embedded Web Server is not protected, then the following permissions 
must be enabled in the Public permissions group to avoid a failed enrollment.

Access Control menu section Access control to enable

Administration Menus Security Menu

Device Management Remote Management
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Lexmark_PCA_User account

When the Printer Configuration Agent (PCA) eSF application is installed on an e‑Task 
version 5 or later printer, a Lexmark_PCA_User account and an administrator group are 
created. This account is used to process requests from Cloud Fleet Management.

Note: The Lexmark_PCA_User account and the administrator group must not be 
changed or modified. Changing them after enrollment prevents the printer from 
processing Cloud Fleet Management requests.

If any of the following actions occur after the printer is enrolled, then Cloud Fleet 
Management functionality may be lost. To restore Cloud Fleet Management functionality 
without reenrolling the printer, do the following resolution actions:
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1.

2.

3.

1.

2.
3.

1.

2.

Action Resolution

Lexmark_PCA_User account has been 
deleted. Recreate the Lexmark_PCA_User 

account.
Open the Printer Configuration Agent 
application.
Click Update Credentials, and then 
enter the credentials of an existing 
administrator account on the printer.

Lexmark_PCA_User account name has 
been changed.

Click Update Credentials, and then enter 
the credentials of an existing administrator 
account on the printer.

Lexmark_PCA_User account password has 
been changed. Open the Printer Configuration Agent 

application.
Click Test Agent Connection.
Click Update Credentials, and then 
enter the credentials of an existing 
administrator account on the printer.

Administrator group has been deleted.
Recreate the administrator group with 
all permissions enabled.
Assign the recreated administrator 
group with the Lexmark_PCA_User 
account.

Administrator group permissions have been 
changed.

Re‑enable all permissions under the 
administrator group.

Lexmark_PCA_User account removed from 
the administrator group.

Reassign the Lexmark_PCA_User to the 
administrator group.

e‑Task version 4 or earlier printers

Printers with e‑Task version or earlier have a light gray control panel background.
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Secured Printers

If a Basic Security Setup template has been applied, then provide the credentials in the 
Printer Enrollment Tool during the device enrollment process. If this protection was applied 
or modified after the printer was initially enrolled, then the printer will not process requests 
from Cloud Fleet Management. For more information, see "Managing enrolled printers" 
group in Lexmark Cloud Services Administrator's Guide.

The following access controls must be set to either the Basic Security Setup template or 
No Security.

e‑Task version Access Controls menu Access control

e3 and e4 Administration menus Service Engineer Menus 
Remotely

e3 and e4 Management Remote Management

e3 and e4 Management Firmware Updates

e4 Management Configuration File Import / 
Export

Open Printers

If access to the Embedded Web Server is not protected, then the following access controls 
must be set to No Security to avoid a failed enrollment.
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1.

2.

e‑Task version Access Controls menu Access control

e3 and e4 Administration menus Service Engineer Menus 
Remotely

e3 and e4 Management Remote Management

e3 and e4 Management Firmware Updates

e4 Management Configuration File Import / 
Export

Using the Local Agent

Using a Local Agent

The Local Agent is a Fleet Management agent for managing USB-connected printers that 
otherwise do not have a means of communicating directly with Cloud Fleet 
Management. For more information on the Fleet Management Agents, see Selecting an 
agent on page 59.

Note: The Local Agent supports Windows 64-bit and Windows 32-bit operating 
systems only

To use a Local Agent, do the following:

Download the Local Agent
Obtain an activation code
Install the Local Agent
Activate the Local Agent

Downloading the Local Agent

From the Fleet Management web portal, click Agents > Local Agents > Download Local 
Agent or Download Agent.
In the Download Local Agent window, select the installer package type.
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3.

◦

◦
◦

4.
5.

Note: You can select the Windows x64 or x86 installer package.

Select Generate activation code.

Notes
The activation code is valid for 72 hours. If you are going to install the Local 
Agent before the activation code expires, then generate the code now.
You can set the number of agents to be activated by the code.
If the code expires before activating the agent, then generate a new activation 
code. From the Fleet Management portal, click Agents > Local Agents > 
Activation Code > Generate activation code.

Click Download Agent.
Accept and download the End‑User License Agreement (EULA).

Note: The Local Agent installation files and activation code can be reused up to the 
number of activations specified when the activation code was generated. After the 
specified number of activations, the code is no longer valid, to prevent using it on 
more workstations than intended.

Downloading the Local Agent again
If the Local Agent is downloaded while a valid activation code exists, then the activation 
code appears when the Local Agent installation package is downloaded. The time 
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1.

2.

remaining until the activation code expires and the number of activations remaining are 
shown. Click Download Agent to download the installation package.

Obtaining the activation code

To use the Local Agent, you need an activation code. An activation code can be generated 
when the Local Agent installer is downloaded. For more information, see Downloading the 
Local Agent on page 102. You can also obtain the activation code by doing the following:

From the Fleet Management web portal, click Agents > Local Agents > Activation Code > 
Generate activation code.

In the Generate activation code window, set the number of agents to be activated by the 
code.
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3.

4.

Click Generate Code.

If a valid activation code already exists, then you can view it by clicking the Activation Code 
menu.

Click Copy activation code

Note: The time and the number of remaining activations for which the code is valid 
are shown.

Managing the activation code

If a valid activation code already exists, then you can view it by expanding the Activation 
Code menu.
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2.
3.

Updating the number of activations allowed

The Local Agent installation files and activation code can be reused up to the number of 
activations specified when the code was generated. After the specified number of 
activations, the code is no longer valid. To increase the number of allowed activations for a 
valid activation code, do the following:

From the Fleet Management web portal, click Agents > Local Agents > Activation Code > 
Update the number of supported activations.
In the Update the number of supported activations window, set the number.
Click Update Activations.
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1.

2.

1.
2.

1.

2.

Note: If an activation code has expired, then you must generate a new one. You 
cannot increase the activations allowed for an expired activation code. Activation 
codes are valid for up to 72 hours.

Invalidating an activation code

If you no longer need a valid activation code, then you can force its expiration.

From the Fleet Management web portal, click Agents > Local Agents > Activation Code > 
Expire activation code.
In the Expire activation code window, click Expire Code.

Installing and activating a Local Agent

The Local Agent is designed to be installed on a Windows 64-bit or Windows 32-bit 
operating system. The downloaded Local Agent package must be extracted before it can 
be installed and then activated.
Installing the agent manually

To manually install the Local Agent, execute the Local Agent msi file. Follow the on-screen 
prompts. After the installation has completed, the Local Agent must be activated.

Note: The Local Agent msi file must be executed from the same folder as the 
configuration .ini files.

Run the Local Agent MSI file.
Follow the instructions on the computer screen.

Activating the agent manually

To manually activate the Local Agent, find and open the Lexmark Local Agent entry in the 
Windows menu.

Enter the activation code, and then click Activate Agent.
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The following message appears

If the activation of the Local Agent fails, then the following message appears:

Make sure that the activation code is correct, or generate a new activation code.

Activating the agent during installation

You can configure the Local Agent to automatically activate during installation by adding 
the activation code to the LocalAgentConfig.ini file.

Unzip the installation package.
Open the LocalAgentConfig.ini file in a text editor.
Under the [IOT_HUB] block, add the CS_ACTIVATION_CODE parameter.
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5.
6.

•

•

•

•

•

•

1.

Enter the activation code generated from Lexmark Cloud Services as the value of the 
parameter.

Sample code:

[IOT_HUB] 

   CS_ACTIVATION_CODE=ab23ftcd-12dt-edte-123hdtdk-ttrbd

Save the LocalAgentConfig.ini file.
Run the Local Agent MSI file.

Notes

The Local Agent msi file must be executed from the same folder as the configuration 
ini files.
If the activation code has expired, or was incorrectly copied into the 
LocalAgentConfig.ini file, then the Local Agent is installed, but is not activated. To 
verify the activation status of the Local Agent, click Agents > Local Agents.

Managing an installed Local Agent

Managing Local Agents includes the following:

Updating the Local Agent version. For more information, see "Updating the Local Agent" 
topic in Lexmark Cloud Services Administrator's Guide.
Editing the configuration of Local Agents or deactivating or deleting a Local Agent. For more 
information, see "Editing the Local Agent" topic in Lexmark Cloud Services Administrator's 
Guide.

Editing the configurations of a Local Agent

Local Agents have two configurable parameters:

Log level—Must be set to Detailed. Detailed logs provide information on errors, warnings, 
and debugging.
Polling Interval—How often the Local Agent reports printer data back to the Fleet 
Management services. The default value is 180 minutes.

Editing the Local Agents

From the Fleet Management web portal, click Agents > Local Agents.
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2.

◦

◦

1.
2.
3.

4.

1.
2.
3.

Do either of the following:

To edit a single Local Agent, click the name of the Local Agent, and then click Edit 
Agent.

To edit multiple Local Agents at the same time, select multiple Local Agents, and then 
click Edit Settings.

Note: The Edit Local Agent window shows that Log level is set to Detailed 
and Polling Interval is set to 300. These changes are automatically applied 
regardless of the current settings of the selected Local Agents.

Deactivating a Local Agent

To stop the Local Agent from collecting and reporting printer information to the Fleet 
Management services, you can deactivate it. After reactivating a Local Agent, you can 
reactivate it only by applying a valid activation code.

From the Fleet Management web portal, click Agents > Local Agents.
Click the name of the Local Agent.
Click Deactivate Agent.

Click Deactivate Agent.

Deleting a Local Agent

If a Local Agent is no longer needed, then it can be deleted from the Fleet Management 
portal. All information related to the agent is deleted.

From the Fleet Management web portal, click Agents > Local Agents.
Click the name of the Local Agent.
To delete a Local Agent, click Delete Agent.
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1.

◦
◦

Click Delete Agent.

Note: Deleting a Local Agent in the Fleet Management portal does not uninstall the 
Local Agent application installed on the workstation.

Deploy applications and configure your printers

Deploying file using configurations

Using configurations

You can deploy configurations to update managed printers from within the Fleet 
Management portal. A configuration can contain one or more of the following categories:

Printer firmware
eSF applications
Printer settings files

You can deploy configurations to one or more printers in a single action. Fleet 
Management services determine the correct version of firmware or eSF applications to 
deploy to each printer.
Deploy configuration in the following order:

Firmware
Applications, in the same order that they appear in the configuration.
Settings files, in the same order that they appear in the configuration.

Creating a configuration

From the Fleet Management portal, do either of the following:

Click Printers > Configure > Create Configuration.
Click Configurations > Configurations > Create.
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◦

▪
▪

◦

▪
▪

◦

In the Create Configuration page, type a unique name and description.

Select one or more of the following:

Firmware

The latest recommended Firmware versions
Special version previously uploaded as a resource in Cloud Fleet Management

Apps

The latest version of the selected eSF applications
Special version previously uploaded as a resource in Cloud Fleet Management

Printer Setting Files
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▪
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•

•

UCF or setting bundle files previously uploaded as a resource in Cloud Fleet 
Management

Click Create Configuration.

Firmware

A configuration can be set up to deploy printer firmware. The firmware can be the latest 
recommended versions or the selected versions, previously uploaded as a resource in 
Cloud Fleet Management.

Notes

If the Recommended Firmware option is selected, the latest recommended version 
available whenever the configuration is deployed, will be used.
Firmware is deployed first, followed by apps and printer settings.

Recommended firmware

Select Update all models to the recommended firmware version to deploy the latest 
recommended version of firmware version. This deploys the latest recommended version 
whenever the configuration is deployed.

Other firmware

You can click Select Firmware to select a specific version from the Resource Library. 
Once you select a specific firmware, it overrides Update all models to the recommended 
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firmware version setting for models that use the specific firmware version. Multiple 
firmware versions can be selected, but only one version per printer model is allowed.

Specific firmware can also be uploaded to the Resource Library and automatically selected 
by clicking Upload Firmware, and then completing the form. For more information, see 
Using Cloud Print Management clients on page 142.

Apps

A configuration can deploy eSF applications to printers. The applications deployed can be 
standard eSF applications or the ones uploaded to the Resource Library.

Note: Apps are deployed after firmware and in the order that they appear in the 
Apps list.

Select Apps

Click Select Apps to see eSF applications available for deployment

This list contains both the standard eSF applications, and those previously uploaded to the 
Resource Library. You can select one or more applications from the list, and then click 
Next to review your selection.
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After reviewing the form, click Done.

Upload Apps

An eSF application can be uploaded to the Resource Library and automatically selected by 
clicking Upload Apps, and then completing the form. The application file selected must be 
an .fls file. The uploaded application will be automatically added to the list of applications 
included in the configuration. For more information, see Using Cloud Print Management 
clients on page 142.
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Applications that have been uploaded to the Resource Library can be selected from the 
Apps catalog. Apps from the Resource Library are shown with the category type of 
Imported app.

App settings

eSF applications may have configurable settings that can be deployed with the application. 
The settings available for each application can be viewed by clicking the arrow next to the 
name of the eSF application. Edit the settings to fit your specific needs. Repeat this 
process for each application in the configuration.
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Printer Settings

A configuration can be used to deploy printer settings files. The settings file must be 
uploaded to the Resource Library before they can be deployed.
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◦
◦

Note: Settings will be deployed after firmware and apps, and in the order that they 
appear in the list.

Select Settings

Settings files that have been previously uploaded to the Resource Library can be selected 
by clicking Select Settings. To establish the proper settings for your needs, select one or 
more setting files, and then click Select Settings.

Upload Settings

A printer settings file can be uploaded to the Resource Library and automatically selected 
by clicking Upload Settings and completing the form. The settings file must be a UCF or a 
Setting Bundle file. The uploaded settings file is automatically added to the list of settings 
files included in the configuration. For more information, see Using Cloud Print 
Management clients on page 142.

Using a Resource Library

The Resource Library is a repository for your custom files that can be deployed to printers 
as part of a configuration. Resource files consist of the following types:

Firmware
eSF applications
Printer setting files

Universal Configuration Files (UCF)
Bundles

There are two ways to add items to the Resource Library:
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2.

3.

Add files to the Resource Library for later use
Add files to the Resource Library while creating a configuration

Adding files to the Resource Library

From the Fleet Management portal, click Configurations > Resource Library.

Click Create Resource or Create.

In the Create Resource window, do the following:
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▪

▪

▪

▪

▪

▪

▪

Type a unique name and description.
From the Type menu, select any of the following:

UCF file—Files with a .ucf or .txt extension that contain printer or eSF 
application settings. Click Choose File to browse to the UCF file.

Notes
You can use UCF files to clone settings from one printer to 
another or to define a standard configuration for printers.
UCF files are the preferred method of deploying settings to 
older‑generation printers, with firmware versions beginning with 
LW and LHS.

Settings bundle—Settings bundle are files with a .zip extension that contains 
printer or eSF application settings. You can click Choose File to browse for the 
settings bundle.

Notes
You can use Settings bundle files to clone settings from one 
printer to another or to define a standard configuration for printers.
Settings bundles are the preferred method of deploying settings to 
the current‑generation printers, with firmware versions beginning 
with CS, CX, MS, and MX.

Firmware—Special versions of printer firmware that you can be add as a 
resource. Enter a specific firmware version, such as CSTAT.076.303, or a link 
provided by the Lexmark Customer Support Center for a specific version, and 
then click Verify. If the version or link is valid, then information about the 
firmware version is shown. An error is shown if the requested firmware cannot 
be found.
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▪

Note: If an error appears, then verify that the firmware version number, 
or the link provided by Lexmark. If the error persists, then contact the 
Lexmark Customer Support Center.

Imported app—eSF applications that are not available in the standard Cloud 
Fleet Management application catalog. These files have an .fls extension. Click 
Choose File to browse for the esf application file. When a valid file has been 
selected, information about the eSF application is shown. An error is shown if 
the requested eSF application file is not valid.
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4.

Note: If an error appears, then verify that the name is correct and that 
the file is an eSF application file. If the error persists, then contact the 
Lexmark Customer Support Center.

Click Create Resource.
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3.

◦

◦

4.

1.

Adding files to the Resource Library while creating a configuration

You can add files to the Resource Library while creating a configuration. For more 
information on creating a configuration, see "Creating a configuration" topic in Lexmark 
Cloud Services Administrator's Guide.

Adding firmware to a configuration and the Resource Library

From the Firmware tab on the Create Configuration page, click Settings > Upload 
Firmware.
Type a unique name and description.

Enter a specific firmware version, such as CSTAT.076.303, or a link provided by the 
Customer Support Center for a specific firmware version, and then click Verify.

Notes
If the version or link is valid, information about the firmware version is shown. 
An error is shown if the requested firmware cannot be found.
If an error appears, then verify that the firmware version number, or the link 
provided by Lexmark, is entered correctly. If the error persists, then contact the 
Lexmark Customer Support Center.

Click Upload Firmware.

Adding apps to a configuration and the Resource Library

From the Apps tab on the Create Configuration page, click Apps > Upload App.
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2.

3.

◦

◦

◦

Type a unique name and description.

Click Choose File to browse to the esf application file.

Notes
The file name must be an FLS file. The uploaded application is automatically 
added to the list of applications included in the configuration.
When a valid file has been selected, information about the eSF application is 
shown. An error is shown if the requested eSF application file is not valid.
If an error appears, then verify that the name is correct and that the file is an 
eSF application file. If the error persists, then contact the Lexmark Customer 
Support Center.
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1.

2.

Click Upload App.

Note: The eSF application is added to the current configuration and added to the 
Resource Library. Applications that have been uploaded to the Resource Library can 
be selected from the Apps catalog. 

Adding a settings file to a configuration and the Resource Library 

From the Printer Settings tab on the Create Configuration page, click Printer Settings > 
Upload Settings.

From the Type menu, select UCF or Settings bundle.
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◦
◦
◦

1.

2.

Click Upload Settings.

Note: You can use UCF files and Settings bundle files to clone settings from one 
printer to another or to define a standard configuration for printers.

Deploying a configuration

You can apply a configuration to multiple printers simultaneously and then reuse it 
anytime.

After a configuration is deployed, it cannot be edited. 
When a configuration is deployed, it deploys the latest recommended versions of the 
standard firmware and eSF applications that it contains.
When a configuration is deployed, there is an implicit order of deployment to the printer.

Firmware
Applications, in the same order that they appear in the configuration
Settings files, in the same order that they appear in the configuration

From the Fleet Management portal, click Printers > Configure > Deploy configuration.

Choose the configuration to deploy, and then click Deploy configuration.
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Note: You can view the status of the deployment in the Tasks tab.

Redeploying a configuration
Configurations can be redeployed as many times as needed. Each time it deploys the 
latest recommended versions of the standard firmware and eSF applications that it 
contains. Items added from the Resource Library retain their original version.
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Managing a configuration

After creating configurations, you can edit, copy, or delete them, or set them as default 
configurations.

Note: After deploying a configuration, it cannot be edited.

You can access the list of configurations by clicking Configurations > Configurations.
You can also access the list of configurations by clicking Printers > Configure > Manage 
configurations.
Editing a configuration

Only configurations that have not been deployed can be edited. These configurations are 
indicated by a No in the Deployed column.

From the Configurations page, click the name of the configuration.
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◦

◦

Note: If the name of a deployed configuration is clicked, an error message is shown.

Edit the configuration, and then click Save Changes.

Copying a configuration

To copy a configuration do one of the following.

From the Configurations page, select a configuration, and then click Copy.

Click the name of a deployed configuration, and then click Copy Configuration.
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1.
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Type the name of the new configuration, and then click Copy Configuration.

Note: Selecting Edit configuration after copy opens the newly created configuration 
in edit mode.

Note: Users with the Partner Administrator role can copy a configuration to any 
organization under the channel partner’s parent organization by entering the name 
of the destination organization.

Deleting a configuration

From the Configurations page, select one or more configurations.
Click Delete > Delete configuration.

Setting or removing a default configuration

A configuration can be designated as a default configuration. A default configuration is 
automatically deployed to newly enrolled printers.

Setting a default configuration
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1.
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From the Configurations page, select a configuration, and then click Set as Default.
Click Set as Default.

Removing a default configuration

From the Configurations page, select a configuration, and then click Remove Default.
Click Remove Default.

Deploying files without using a configuration

Deploying a firmware

You can update firmware without including it in a configuration. Firmware can either be 
updated now or you can schedule the update at a later time.

From the Fleet Management portal, in the Printers page, select one or more printers.
Click Configure > Update Firmware.
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3.

◦

◦

In the Update Firmware window, select any of the following:

Now—Sends an Update firmware task to the agent associated with each selected 
printer. The latest recommended version of firmware is sent to each selected printer.

Note: This may adversely affect latency on your network.

Specific date and time—Schedule the firmware updates in order to minimize network 
latency and impact on your business operations.
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The Update Firmware window shows date and time selection options. Firmware on the 
selected printers are updated at the date and time specified. An Update firmware task 
is sent to the agent associated with each selected printer at the date and time 
specified. The latest recommended version of firmware is sent to each selected printer.

When should the firmware update occur?

This menu toggles the Update Firmware window between the Now and Specific date and 
time options.

Scheduled task name

This field allows you to name the firmware update operation. This name is used to identify 
the update task on the Schedule page.
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You can make changes to a scheduled task before it starts by clicking on the name of the 
task. You can also delete tasks that have not yet started by selecting them, and then clicking 
Delete.

Note: Once a scheduled task has started, it cannot be modified nor deleted.

Start date, Start time, and Time zone

These fields determine when the Firmware update task will start. The time zone field allows 
you to regionalize the start time. This is helpful if the locations of your printers span multiple 
time zones.

Task window

The task window parameters determine how much time will be allowed to update the 
firmware on all the selected printers. They are used to set a time limit on the duration of the 
updates to minimize the impact on your network. No firmware updates will be initiated after 
the task window expires.
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4.

1.
2.

3.

Notes
Any firmware update job that is not launched in the specified task window will 
expire.
If you are updating firmware for multiple printers, then make sure that the task 
window is large enough.
For a large number of printers, divide them into batches to further minimize the 
network impact.

Click Update Firmware.

Deploying applications and settings

You can deploy printer applications and settings files to printers without having to create a 
configuration.

Note: This deployment is for one time only and is not saved for reuse.

From the Fleet Management portal, in the Printers page, select one or more printers.
Click Configure > Deploy apps and settings file.

In the Upload Files window, click Choose Files to browse for the application and settings file 
or drag and drop the files onto the Upload Files window, and then click Done.
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Customize your print environment

Cloud Print Management overview

Cloud Print Management lets you securely submit and release print jobs at an enabled 
printer and then capture that activity in Analytics. There are several ways you can choose 
to submit and release print jobs and any or all may be used in your organization. The 
various ways of submitting and release print jobs are as follows:

Print Release
Hybrid Print Release
Direct Print

Notes

All methods require connectivity with Lexmark Cloud Services.
All printers used with Cloud Print Management must be enrolled in Cloud Fleet 
Management.

Print Release

Print Release lets you submit print jobs to Lexmark Cloud Services, where they are 
securely stored while waiting to be printed. To print submitted jobs, log in at a printer 
configured for Print Release and then select the jobs that you want to print. The printer 
reports the job metrics to the Analytics services for your review and analysis.

Print jobs may be submitted using any of the following methods:

A client application on the workstation
Dragging-and-dropping in the Cloud Print Management portal
A print extension added to the Google Chrome browser
The Lexmark Print application for the iOS operating system software or the Android platform
An e-mail sent to an address configured for your organization
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Hybrid Print Release

When you print using Hybrid Print Release, a client application on their workstation 
securely stores the print job on your workstation and then informs Lexmark Cloud Services 
that a user has a hybrid print job ready to be released. When the user authenticates, and 
selects their print job for release, the printer communicates directly with your workstation to 
release the print job. The print job never leaves your organization’s network.

Note: Make sure that your workstation is online when retrieving the hybrid print job, 
and that a client application is installed on each of your workstations.

Direct Print

Direct Print lets you submit print jobs directly to an administrator-designated, 
network‑connected printer using port 9100 through a client application on your 
workstations. The print job never leaves your organization’s network. The print job never 
leaves your organization’s network.

Using Cloud Print Management

Cloud Print Management roles

Roles must be based upon the users’ needs and job activities. Users who receive access 
to a print release method must have at least one of the following roles:

Users who will be submitting and releasing print jobs:

For Print Release—Print Release Management User
For Hybrid Print Release—Hybrid Print Management User
For Direct Print—Direct Print Management User

Users who will be administering the print environment for their organization:

For Print Release—Print Release Management Administrator
For Hybrid Print Release—Hybrid Print Management Administrator
For Direct Print—Direct Print Management Administrator

Users who need to review the print activity of their organization, but will not be administering 
the print environment:

For all print release methods—Print Release Management Reporting Analyst
Channel Partners who can administer any of the print release methods in their customer’s 
organization must be a member of a Child Organization Access Group that includes the 
appropriate administrator role for the print release method:

Before you can administer a print release method in one of your customer 
organizations, it must be enabled in your organization.

For more information on user roles definition, see "Understanding roles" topic in Lexmark 
Cloud Services Administrator's Guide.
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Assigning roles

User roles are managed from the Account Management portal. You can assign roles to 
users in three ways:

Assigned to an individual user—Requires assigning roles manually to each user.
Assigned through group membership—Allows a set of roles to be given to users by 
making them a member of a group. Users can be members of more than one group.
Assigned as an organization role—Automatically assigns the organization roles to all 
users in the organization.

Note: The assignment method depends on the needs of the organization. For more 
information, see "Overview" topic in Lexmark Cloud Services Administrator's 
Guide.

Understanding Cloud Print Management administrative options

Various Cloud Print Management features and functions can be tailored through the 
Organizational Settings menu. From the Print Management portal, click Administration > 
Organizational Settings.

Note: The user must have the Print Release Management Administrator role to 
see and access the Administration menu. For more information, see "Configuring 
organizational settings" topic in Lexmark Cloud Services Administrator's Guide.
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Deploying the Cloud Print Management bundle

Before you can use Cloud Print Management to release print jobs, you must deploy the 
Cloud Print Management eSF application bundle.
Creating a configuration for Cloud Print Management
The eSF applications that make up the Cloud Print Management bundle are deployed from 
the Fleet Management portal by creating a configuration. For more information on creating 
a configuration, see "Creating a configuration" topic in Lexmark Cloud Services 
Administrator's Guide.
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Note: Only printers managed by Cloud Fleet Management can have the Cloud 
Print Management bundle deployed from the Fleet Management portal.

Deploying a Cloud Print Management configuration

You can apply a configuration to multiple printers simultaneously and then reuse it 
anytime.

From the Fleet Management portal, click the Printers tab.
Select one or more printers, and then click Configure > Deploy configuration.
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3. In the Deploy Configuration window, select the configuration, and then click Deploy 
configuration.
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Note: For more information on deploying a configuration, see "Deploying a 
configuration" topic in Lexmark Cloud Services Administrator's Guide.

Using Cloud Print Management clients

To use Cloud Print Management, Hybrid Print Release, or Direct Print, you must install the 
Lexmark Print Management Client (LPMC) client application on the users’ workstations.

Downloading a client package

You can download the LPMC from the Print Clients tab in the Print Management portal.

From the Print Management portal, click Print Clients.
In the Print Clients page, do the following:
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From the Select client menu, select any of the following:

Windows®
macOS®
Ubuntu
Chrome—The Cloud Print Management for Google Chrome™ extension on the 
Chrome Web Store for use with the Google Chrome operating system and 
Chrome browser
iOS—The Lexmark Print application for iOS on the Apple App Store online store
Android™ —Lexmark Print application for Android on Google Play™ store
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Note: If you select Chrome, iOS, or Android, then you are provided a link to 
the external site for the Lexmark Cloud Services print client application.

From the Select Package Type menu, select any of the following:

Note: You can download an LPMC package with default settings for Cloud 
Print Management, Hybrid Print Release, or Direct Print. You can also create a 
customized LPMC package by selecting the Custom Package option.

Cloud Print Management
Hybrid Print Management
Direct Print
Custom Package

If you selected Cloud Print Management or Hybrid Print Management, then click Download 
Client to download the package.

If you selected Custom Package, then you have to create a custom package.

Note: If you selected Direct Print, then see "Using Direct Print"  topic in  Lexmark 
Cloud Services Administrator's Guide.

Creating a custom LPMC package

The Custom Package option lets you create an LPMC installation package that is suited to 
your needs. To customize, you can do any of the following:

Combine one or more submission types in a single package. A single package can include 
Cloud Print Management, Hybrid Print Management, and Direct Print.
Change global client settings.
Select the print driver to install.
Set an LPMC print queue as the default print queue on the workstation.
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Once the custom package is ready, click Create > Download.

Note: The package is a compressed file that must be extracted before installation.
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Installing Lexmark Print Management clients on workstations

After downloading default LPMC client applications, from the Client Download page, you 
can install them on workstations. For custom packages, you must extract the downloaded 
file before installing them. For more information on installing LPMC, see "Installing the 
Lexmark Print Management Client" topic in Lexmark Cloud Services Administrator's 
Guide.

Printing with Cloud Print Management

You can submit print jobs using the following ways:

From your workstation
From your print queue in the Print Management portal
From your mobile device

Printing from your workstation

From your workstation, you can submit print jobs by doing one of the following:

From a desktop application, select File > Print, and then select a Print Management queue.
From the Google Chrome operating system or browser, select File > Print, and then select a 
Print Management queue.

Note: To print from the Chrome operating system or browser, you must install the 
Lexmark Cloud Print Management for Chrome extension. For more information, see 
"Sending print jobs from the Chrome OS operating system" in Lexmark Cloud 
Services Administrator's Guide.

Using email

Note: Your organization must be configured to accept print jobs using email. For 
more information, see "Sending print jobs using e-mail" topic in Lexmark Cloud 
Services Administrator's Guide.

Submitting a print job in the Print Management portal

From the Print Management portal, click Print Queue > Upload File.
Drag and drop files in the Upload File window or click Choose Files to browse to the file you 
want to print.
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Click Done.

Submitting a print job from your mobile device

Print jobs can be submitted from devices running the iOS operating system software or the 
Android platform. For more information, see "Mobile printing" group in Lexmark Cloud 
Services Administrator's Guide.

Using Cloud Print Management with third‑party printers

You can use Cloud Print Management with printers that do not support eSF applications, 
including Lexmark printers that are not solutions‑enabled and printers from third-party 
manufacturers.
Cloud Print Management is enabled on these printers by using the ELATEC TCP3 adapter, 
a device that connects between the customer’s network and the printer. It also provides a 
USB connection for badge or card readers. The TCP3 adapter handles all user badge or 
card authentication and passes the user’s print jobs from Lexmark’s Cloud Print 
Management service to the printer. For more information, including limitations on using the 
ELATEC TCP3 adapter, see "Printing jobs from third-party printers using Cloud Print 
Management" topic in Lexmark Cloud Services Administrator's Guide.

Note: The Elatec TCP3 Adapter receives power either from an external 5Volt 
power source or from an Ethernet connection that supports power over ethernet. 
See the Technical Manual provided with the Elatec TCP3 for more details.
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Using Direct Print

Direct Print overview

Direct Print lets you submit print jobs directly to an administrator-designated, 
network‑connected printer using port 9100 through a client application on your 
workstations. The print job never leaves your organization’s network.
Print jobs are sent using port 9100 by the Lexmark Print Management Client (LPMC) 
directly to an administrator-designated, network‑attached printer. When using the Direct 
Print feature, print jobs never leave your organization’s local network. The LPMC reports 
job metrics to Lexmark Cloud Services.
Enabling Direct Print

Enroll printers for Direct Print in Cloud Fleet Management and assign a tag to them. For 
more information, see Assigning printers to Direct Print on page 149.
Enable Direct Print for the organization. For more information, see Enabling Direct Print on 
page 149.
Create Direct Print assignments. For more information, see Creating Direct Print 
assignments on page 150.
Download and install the Lexmark Print Management Client configured for Direct Print. For 
more information, see Using Direct Print clients on page 156.

Notes

You must have the Direct Print Release Administrator role.
Connectivity with Lexmark Cloud Services is required.
A Direct Print configuration file must be applied when the LPMC is installed to enable 
Direct Print functionality.
Printers used by Direct Print must be enrolled in Cloud Fleet Management.

Printing with Direct Print
You can submit print jobs by clicking File > Print from desktop applications, and then 
selecting a Direct Print queue.

Note: Using Direct Print to submit jobs is supported in desktops only, not in mobile 
devices.

Direct Print roles

Users given access to the Direct Print feature of Cloud Print Management must have at 
least one of the following roles based on tasks that they plan to perform:

Users submitting and releasing print jobs using Direct Print must have the Direct Print 
Management User role.
Users managing Print Management for their organization must have the Direct Print 
Management Administrator role.
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Users generating organizational Cloud Print Management reports but do not have the Direct 
Print Management Administrator role must have the Print Release Management 
Reporting Analyst role.
Channel partners who manage printers in their customers’ organizations must be members 
of a Child Organization Access Group. The group must have the Direct Print Management 
Administrator role assigned to it.

Notes
Before a channel partner can administer Cloud Print Management in a 
customer organization, you must enable Cloud Print Management in the 
channel partner’s organization. For more information, see "Assigning roles" 
group in Lexmark Cloud Services Administrator's Guide.
For more information on roles, see "Understanding roles" topic in Lexmark 
Cloud Services Administrator's Guide.

Assigning roles

User roles are managed from the Account Management portal. You can assign roles to the 
users in the following ways:

Assigned roles individually—Requires that assigning roles manually to each user.
Assigned roles through groups—Allows a set of roles to be given to users by making 
them a member of a group. Users can be members of more than one group.
Inheritance through organization roles—Automatically assigns the organization roles to 
all users in the organization.

The assignment method depends upon the needs of the organization. For more 
information, see "Assigning roles" group in Lexmark Cloud Services Administrator's 
Guide.

Assigning printers to Direct Print

Printers used with Direct Print must be enrolled in Fleet Management. Each printer must 
also have at least one Fleet Management tag applied to it.
For more information on enrolling printers in Fleet Management, see "Enroll your printers" 
chapter in Lexmark Cloud Services Administrator's Guide.
For more information on applying tags to printers, see the following:

"Creating tags" topic in Lexmark Cloud Services Administrator's Guide
"Assigning tags to printer" topic in Lexmark Cloud Services Administrator's Guide

Enabling Direct Print

Direct Print is enabled on the Print Management Organizational Settings page.

From the Print Management web portal, click Administration > Organizational Settings.
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Select Enable direct print.
Select whether to use a cost center or a department.

Notes

The Direct Print assignment applies to all members of the designated cost center or 
department. In either case, Direct Print assignments can also be applied to individual 
users.
You must have the Direct Print Release Administrator role to enable Direct Print.
Users must have the Direct Print Release User role to use Direct Print.
Cost centers and departments are defined and assigned to users in the Account 
Management portal.

If Direct Print is enabled, then an additional menu item is available in the Administration 
menu.

Creating Direct Print assignments

From the Print Management web portal, click Administration > Direct Print Assignments.
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2. Depending on your requirement, select the Cost Center or Department or Personal tab, 
and then click Create Assignment.

Note: If there are existing Direct Print assignments, then the Direct Print 
Assignments page shows them.
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In the Create Direct Print Assignment window, do the following:

Note: The Direct Print assignment applies to all members of the designated cost 
center or department. In either case, Direct Print assignments can also be applied to 
individual users.

Cost Center or Department assignments—Cost center and department 
assignments are applied to all members of that cost center or department.
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Note: The Create Assignments forms are the same for cost centers and 
departments.

Assignment name—Type a unique assignment name.
Cost center name or Department name—Type the name of the cost center or 
department that will be associated with this assignment. A list of possible 
matches is shown as characters are entered.

Notes
The cost center or department chosen must match one in the 
Account Management portal. If the name entered does not match, 
the caution symbol is shown before the name.
You can apply only one cost center or department to a Direct Print 
assignment.
A cost center or department can only be associated with one 
Direct Print Assignment.
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Tags identifying printers this cost center may use for direct printing— 
Printer tags are used to create the connection between a Direct Print 
Assignment and one or more printers. Type the tag name to be associated with 
this assignment. Multiple tags can be associated with a Direct Print 
assignment. Select a tag name from the list, and then click Add.

Notes
You can use only tags that were previously defined in the Fleet 
Management portal.
When a tag is added, tag names and the total number of printers 
with the added tag names appear.
You can associate an assignment to up to ten printers only. While 
you can save an assignment with more than ten printers, you 
cannot download a Print Client package associated with that 
assignment.

Personal—Apply assignments only to specific individuals.

Assignment name—Type a unique assignment name.
E-mail addresses of registered users to be included in this assignment— 
Type the email address of an individual associated with this assignment. Multiple 
individuals can be associated with the same Direct Print assignment.
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Note: Only users with the Direct Print Release User or Direct Print 
Release Administrator User role are shown.

Tags identifying printers these users may use for direct printing—Printer 
tags are used to create the connection between a Direct Print Assignment and 
one or more printers. Type the tag name to be associated with this assignment. 
Multiple tags can be associated with a Direct Print assignment. Select a tag 
name from the list, and then click Add.

Notes
You can use only tags that were previously defined in the Fleet 
Management portal.
When a tag is added, tag names and the total number of printers 
with the added tag names appear.
You can associate an assignment to up to ten printers only. While 
you can save an assignment with more than ten printers, you 
cannot download a Print Client package associated with that 
assignment. 

Click Create Assignment.

Download Direct Print Client Package Error

If you include an assignment containing more than ten printers when creating a direct print 
client package, then client package download fails. The Direct Print assignment that 
contains more than ten printers must be modified to reduce the number of printers to ten or 
less. The following error message is displayed when a download fails.
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Using Direct Print clients

To use Direct Print, you must install a Direct Print–capable version of the Lexmark Print 
Management Client (LPMC) on a user’s workstation.

Downloading a Direct Print client package

You can download the LPMC configured for Direct Print from the Print Clients tab in the 
Print Management portal. You can create either a default Direct Print package or a Custom 
Package.

Direct Print—Creates an LPMC package that only supports Direct Print.
Custom Package—Allows you to create an LMC package that supports Direct Print along 
with Cloud Print Management, Hybrid Print Management, or both. For more information on 
creating a customer client package, see Using Cloud Print Management clients on page 142.
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Notes

Direct print is only available for the Windows operating system.
The minimum LPMC version is 2.3.1145.0.
The LPMC must be installed with a Direct Print configuration file for Direct Print to be 
available to the user

Selecting a default Direct Print package

From the Print management portal, click Print Clients.
In the Print Clients page, do the following:

From the Select client menu, select Windows®.
From the Select Package Type menu, select Direct Print.

Select one or more Direct Print assignments, and then click Download Client.
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Note: The package is a compressed file that must be extracted before installation.

Creating a custom Direct Print package

You can create a Direct Print package that can include either Cloud Print Management or 
Hybrid Print Management or both.

From the Print management portal, click Print Clients.
In the Print Clients page, do the following:

From the Select client menu, select Windows®.
From the Select Package Type menu, select Custom Package.

Click Create Package.

Select any of the following:

Enable Cloud Print Management
Enable Hybrid Print Management
Enable Direct Print

Select one or more Direct Print assignments, and then click Download Client.
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Note: The package is a compressed file that must be extracted before installation.

Installing Direct Print clients on workstations

After downloading default LPMC client applications, from the Client Download page, you 
can install them on workstations. For custom packages, you must extract the downloaded 
file before installing them.

For more information on the LPMC, see "Installing the Lexmark Print Management Client" 
topic in Lexmark Cloud Services Administrator's Guide.

Printing with Direct Print

You can submit print jobs by clicking File > Print from desktop applications, and then 
selecting a Direct Print queue. Using Direct Print to submit jobs is supported in desktops 
only, not in mobile devices.

Using a secure login code

Using a secure login

User logins can be handled in various ways with Cloud Print Management. One method is 
the use of a secure login code, a one-time authentication code that lets users log in to a 
cloud‑enabled printer. Secure login can be used when the badge or PIN login method is 
not configured, or the user does not have a badge or PIN available. A new secure login 
code must be obtained from Lexmark Cloud Services each time a user logs into a 
cloud‑enabled printer.
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Notes

The secure is valid for 15 minutes.
Secure login code is available when identity federation is used.
A secure login code can be obtained from the Lexmark Cloud Services Print 
Management web portal and from the Lexmark Print application on iOS or the 
Android devices.

Setting up secure login

From the Account Management portal, click Organization > Printer Login Configuration.

In the Printer Login Configuration page, select Standard authentication > Manual/secure 
login. For more information, see "Configuring printer login" topic in Lexmark Cloud Services 
Administrator's Guide.
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Click Save Changes.

Obtaining a secure login code

You can obtain a secure login code in the following ways:

From the My Account page in the Lexmark Cloud Services portal
From the Lexmark Print application on a mobile device.
From the web address: https://us.iss.lexmark.com/device for North America, and https:// 
eu.iss.lexmark.com/device for Europe.

User’s Data Center  Value for <env>

European eu

North American us

From the My Account page

From the Lexmark Cloud Services portal, click your account name, and then click My 
Account.
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In the Printer Login section, click Generate Login Code.

Use the secure login code shown to login to a cloud‑enabled printer.

Note: A secure login code is only valid for 15 minutes. After 15 minutes, you can 
obtain a new code by clicking Refresh Code.

From the Lexmark Print application

Open the Lexmark Print application on a mobile device.
Log in to the Lexmark Cloud Services portal.
Touch the Cloud icon at the bottom of the screen.
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Notes

A secure login code will be shown.
A secure login code is only valid for 15 minutes. After 15 minutes, you can obtain a 
new code by clicking Refresh Code.

From the web address

Open a web browser.
Go to: https://<env>.iss.lexmark.com/device.

User’s Data Center  Value for <env>

European eu

North American us



Rollout Guide

165

3.

1.

2.

Note: To determine the value of <env> , see the address on the browser address 
field when you log in to your Lexmark Cloud Services portal.

Use the secure login code shown to login to a cloud‑enabled printer.

Note: A secure login code is only valid for 15 minutes. After 15 minutes, you can 
obtain a new code by clicking Refresh Code.

Using a secure login code

When secure login is enabled for an organization, the Secure Login icon will appear on the 
control panel.

From the printer home screen, touch Secure Login.

Touch the Login Code prompt.
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3. Enter the secure login code, and then touch Log In.

Note: For more information on obtaining secure login code, either touch How to 
Get Code on the control panel or see Obtaining a secure login code on page 161. 
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Using notification policies

Notification policies overview

Notification policies are a Fleet Management feature that lets the Fleet Management 
Administrator send email notifications when certain conditions occur. You can set the 
policies to send emails when toner is low or when a printer fails to communicate with 
Lexmark Cloud Services. Notification policies are available for:

Supplies
Printer Information

Supplies policies

Generates an email when the toner level threshold has been met or exceeded. Multiple 
supplies policies can be created with different threshold settings to provide notifications as 
supplies are depleted.

Supplies policies are available for:

Toner
Maintenance Kit
Fuser
Photoconductors
Waste Toner Bottle
Transfer Module

Printer Information policies

Generates an email when a printer fails to communicate or report its data to Lexmark 
Cloud Services after the interval threshold has been met or exceeded.

Printer Information policies are available for:

Last data refreshed
Last communicated

The following is an example of an email generated by a Notification Policy.
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Creating a Notification Policy

Creating a supplies policy

Supplies policies notify users by email when the toner level of their printers reaches a 
specified percentage.

Note: You can create up to 50 supplies policies for an organization.

From the Fleet Management web portal, click Notifications > Notification Policies.
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Click the Supplies tab.

Note: If there are existing supplies policies, then the Notification Policies page 
shows them.

On the Notification Policies page, click Create.
Configure the following:

In the Policy name field, type the name of the policy.

The following characters are not allowed in a Policy Name:

< >
&
#
?
`
~
!
%
^
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In the Policy type menu, select a supplies option.
In the “Notify when toner remaining is at” section, set the percentage at which the 
notification is sent.
In the Applies To section, select either of the following:

All printers in this organization—Apply the policy to all printers in the 
organization.

Only printers with specific tags—Apply the policy to specific printers based on 
the tags entered. For more information on tags, see "Creating tags" topic and 
"Assigning tags to printers" topic in Lexmark Cloud Services Administrator's 
Guide.

In the “Apply the policy to printers with the following tags” field, type the 
tags, and then click Add.

Note: You can apply up to 10 tags to a policy.

In the “Notify the following e-mail addresses when the conditions of this policy are met” 
field, type the recipient email addresses, and then click Add.

Notes
You can type up to 10 email addresses.
Make sure that the email address is valid.
You can type an email address from outside your organization.
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◦

◦

In the “Additional information to include in the e-mail notification (Optional)” field, type 
any information that you want to appear in the email body. For example, printer 
location or special access instructions.

Select Include notification data in a .json file as an attachment to attach a JSON 
file of the data associated with the notification.

The following is an example of an email notification.

The following is an example of notification data in JSON format.
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1.

2.

Creating a printer information policy

Printer information policies notify users by email when a printer fails to communicate with 
or report its data to Lexmark Cloud Services. Emails are sent after a specified time has 
elapsed.

Note: You can create up to 50 policies.

From the Fleet Management web portal, click Notifications > Notification Policies.

Click Printer Information tab.
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3.
4.

◦

▪
▪
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▪
▪
▪
▪
▪
▪
▪
▪
▪
▪
▪
▪
▪
▪
▪
▪

Note: If there are existing printer information policies, then the Notification Policies 
page shows them.

On the Notification Policies page, click Create.
Configure the following:

In the Policy name field, type the name of the policy.

The following characters are not allowed in a Policy Name:

< >
&
#
?
`
~
!
%
^
*
|
+
=
;
;
"
{ }
[ ]
\ /
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▪
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In the Policy type menu, select either of the following:

Last data refresh—Send an email notification based on the number of days 
since the last update of printer information or counters.

Set the “Notify when data has not been refreshed after” value to the 
number of days that must elapse before an email notification is sent.

Last communicated—Send an email notification based on the number of days 
since the printer last communicated with Lexmark Cloud Services.

Set the “Notify when a printer has not communicated for” value to the 
number of days that must elapse before an email notification is sent.

e‑mail
In the Applies To section, select either of the following:

All printers in this organization—Apply the policy to all printers in the 
organization.

Only printers with specific tags—Apply the policy to specific printers based 
upon the tags entered. For more information on tags, see "Creating tags" topic 
and "Assigning tags to printers" topic in Lexmark Cloud Services Administrator's 
Guide.

In the “Apply the policy to printers with the following tags” field, type the 
tags, and then click Add.
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▪

◦

◦

Note: You can apply up to 10 tags to a policy.

In the “Notify the following e-mail addresses when the conditions of this policy are met” 
field, type the recipient email addresses, and then click Add.

Notes
You can type a maximum of 10 email addresses.
Make sure that the email address is valid.
You can type an email address from outside your organization.

In the “Additional information to include in the e-mail notification (Optional)” field, type 
any information that you want to appear in the email body. For example, printer 
location or special access instructions.

Select Include notification data in a .csv file as an attachment to attach a CSV file 
of the data associated with the notification.

The following is an example of a notification email for last data refresh:
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The following is an example of a notification email for last communicated:
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1.

The following is an example of the notification data in CSV format:

Managing notification policies

Modifying a notification policy

You can modify notification policies at any time.

From the Fleet Management web portal, click Notifications > Notification Policies.
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2.
3.

4.

Select the Supplies or Printer Information tab.
Click the name of the policy that you want to modify.

Modify the policy, and then click Save Changes.
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Duplicating a notification policy

You can duplicate notification policies to create additional policies.

From the Fleet Management web portal, click Notifications > Notification Policies.
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2.
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4.

Select the Supplies or Printer Information tab.
Select an existing policy, and then click Duplicate.

Type a new policy name, and then modify the details as required.
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◦

◦

5.

Notes
When duplicating a policy, the Create Notification Policy page is prefilled with 
information from the policy that you are duplicating.
Make sure that the new policy has a unique name.

Click Create Policy.
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1.

2.
3.

4.

1.

Deleting a notification policy

You can delete notification policies that are no longer needed.

From the Fleet Management web portal, click Notifications > Notification Policies.

Select the Supplies or Printer Information tab.
Select one or more policies, and then click Delete.

Click Delete Policy.

Viewing notification history

The Notification History menu option shows the notifications that were generated in the last 
30 days.

From the Fleet Management web portal, click Notifications > Notification History.
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2.

◦

◦

Select the Supplies or Printer Information tab.

You can view the following notifications generated in the last 30 days:

Supplies notification

Printer Information notification
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