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Unable to Install/Add a Universal Print Driver (UPD) on the Client Computers from Windows Server 2012 R2

Document ID:SO8206

Usergroup :External
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Solution

What you will see

The client computer exhibits the following errors when adding or installing a printer driver from the server (Windows Server 2012 R2):

Windows cannot connect
to the printer 0x00000002
Windows cannot connect
to the printer 0x00000057

  

Root cause

A corrupted driver store's Lexmark print driver folder causes the issue. This is not caused by any Lexmark component as the driver store folder structure is maintained by Microsoft.

 

Workaround

NOTE: Before the driver package can be removed, the name must be identified in the driver store. The .inf file name is changed to oem#.inf (where # is a unique number).

Follow the procedure below to determine the name of the Lexmark driver package from the computer’s driver store and how to delete it. 
 

Step Action
1

Open a command prompt that has administrator privileges.

To do this, Click Start > All Programs >Accessories, Right-click Command Prompt, then click Run as Administrator.
 

2

From the command prompt, type pnputil -e c:\temp\list.txt.
 

3

After the command has executed successfully, browse to the folder location c:\temp\ to look for a text file named, list.txt.

This will contain the entries in the output to find the description of your package and its OEM inf file name.
 

4

Type pnputil -d oem#.inf to delete the identified driver package.

Note: oem# is the corresponding driver inf file name for each Driver package provider. Make sure the # is replaced with the numbers identified in the list that was created in step 3.
 

5 Repeat step 2 to verify if the driver packages have been deleted.
 
6 Add the printer again to see if the issue still persists.
 

 

Still need help?

If you need additional assistance, please close this browser tab or go to the Lexmark support site, type your printer model and locate Get in Touch with Lexmark! for contact information. NOTE: When calling for support, you will need the following:

  • Affected printer model/'s
  • Printer serial number

Please be near the product/s described in this article to expedite the support process and reduce callbacks.


 



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